libc6 dependency probl;em in dapper

Derek Broughton news at
Tue Mar 14 13:29:22 UTC 2006

Tony Arnold wrote:

> I've just tried doing a dist-upgrade on my dapper trial system that I've
> not touched for several weeks. It's hit a problem in that libc6-i686 is
> dependent on libc6 (=2.3.5-ubuntu17), however, libc6_2.3.6-0ubuntu9 is
> actually installed.
> There seem to be quite a few packages that depend on libc6, so removing
> does not seem to be an option.
> I've tried the -f install option to apt-get, but to no avail.
> Anyone else seen this problem? Any suggestions for a workaround?

I got bitten, too.

dpkg --purge libc6-i686
aptitude dist-upgrade
aptitude install libc6-i686

Remember, you don't ever need libc6-i686, it's just more efficient than
using the unoptimized libc6.

In my case, I got stuck and had to reboot - and my LVM volumes wouldn't
mount, I couldn't even use "ls", and I couldn't use dpkg to install
anything because "tar" wouldn't work either.

More information about the ubuntu-users mailing list