dapper + powerbook g4 = no sound?

Matthew Nicholson sjoeboo at sjoeboo.com
Fri Mar 3 13:32:03 UTC 2006


On Thu, 2006-03-02 at 23:50 -0500, Larry Grover wrote:
> Matthew Nicholson wrote:
> > just did an install of dapper on my powerbook g4, and, simply put,
> > everything went great. after a bit of hacking around the air port
> > extreme is working well and a few glitches i saw on a previous install
> > have cleared up.
> > 
> > however, currently, there is no sound. alsamixer/gnome-mixer have both
> > been used and the "normal" things are turned up. i even booted back into
> > OSX to make sure teh volume there wasn't set very low incase it was
> > hardware controlled. no dice.
> > 
> > any advice/help?
> 
> 
> On my new iBook G4, running dapper, I do not get any sound unless I 
> unmute/select the "PC Speaker".  You can do this from a terminal window 
> (run "alsamixer", user the right arrow key to select "PC Speak", and hit 
> the "m" key to unmute), or from the gnome-volume-control (make sure "PC 
> Speaker" is checked, under the "Switches" tab).
> 
> This setting seems to get reset periodically, maybe when I update the 
> system, and I lose sound until I repeat the steps above.  Maybe doing 
> this will restore your sound?
> 
> Now, do you mind sharing what you did to get airport extreme working?
> 
> I've spent literally hours trying to get it working -- googling, 
> reading, compiling, etc -- and it just doesn't work for me.
> 
> I have the firmware installed correctly and I can modprobe the bcm43xx 
> modules with no errors.  I can configure the interface manually with no 
> errors.  I can scan (iwlist eth1 scan) and I see my access point.  I can 
> ping the interface (eth1) address.  I can see traffic on my LAN 
> (tcpdump).  As far as I can tell, the routing table is set correctly.
> 
> I cannot get a dynamic address (dhclient times out), or ping my gateway 
> or any other address on my LAN or the internet.  DNS lookups time out, 
> and, of course, I cannot connect to any host on my LAN or internet.
> 
> I'd really appreciate any tips or pointers.  I'd really like to get my 
> airport extreme card working.
> 
> Regards,
> Larry
> 
Thanks for teh advice, however, it doesn't seem to do much :-9 oh well.
as for the airport extreme, my issues was that, when running a dmesg
with bcm43xx already inserted (and teh firmware in teh right place), i
was getting an error/warning complaining that ieee80211_crypt_wep
couldn't be found or inserted. this is after i had compiled/install
softmac. so, i did a make uninstall on softmac, and did and apt-get
install ieee80211-source, which gives you a tar ball in /usr/src. you
extract it, and compile it. (need linux-headers-`uname -r` installed to
compile) and form there on out, everything has gone smoothly. i only
need to compile the ieee80211 stack for wep, on the schools unencrypted
network, everything was working. hopefully this helps you.





More information about the ubuntu-users mailing list