[Dapper] How to get mounted disk show on the desktop

Alan McKinnon alan at linuxholdings.co.za
Wed Mar 1 09:16:33 UTC 2006


On Tuesday, 28 February 2006 23:39, Vincent Trouilliez wrote:
> On Tue, 2006-02-28 at 22:03 +0100, Guido Heumann wrote:
> > Am Montag, 27. Februar 2006 19:20 schrieb Vincent Trouilliez:
> > [...]
> >
> > > In my experience, it won't take effect immediately though,
> > > even restarting Nautilus wasn't enough, even logging out wasn't
> > > enough, I had to reboot the machine, somehow.
> >
> > Hi Vince,
> >
> > a little hint for future experiments with GNOME configuration
> > settings: there's at least one more thing you can do before
> > rebooting, if logging out doesn't help: restarting GDM. From the
> > login screen, switch to the console with ctrl-alt-F1 and then
> > sudo /etc/init.d/gdm restart.
> >
> > Just in case you didn't know. In my experience this sometimes
> > saves me a desperate reboot.
>
> Yeah I could have tried restarting X, but back then I also had a
> kernel update in the pipeline, so since I HAD to reboot anyway, I
> didn't try too hard avoiding to...
> But I was very surprised that logging out was not enough. I thought
> that Nautilus/Gnome being at user lever, logging out should
> re-initialize each and every component of Gnome. I would not mind
> an explanation here, I feel this would give me a little more
> knowledge of my Penguin...

It's quirky isn't it? A superficial explanation means we have to dig 
into the guts of the system a bit:

X and Gnome are designed to display stuff on the screen and work the 
keyboard and mouse. Other services are controlling the hardware, and 
making things like partitions and memory sticks visible. If Gnome 
can't see them, it won't display them. And it isn't Gnome's job to 
try and second-guess the OS and figure out what's available.

Letting Gnome know that there's a memory stick available involves 
serious deep dark voodoo stuff like udev, namedev, sysfs, hotplug, 
hal, dbus and their friends. So Gnome isn't the only component 
involved, I suspect that restarting hal may have solved your problem 
in this specific case. Restarting Gnome simply put you back exactly 
where you started.

Unless you are a coding freak it's probably a good idea to treat this 
stuff like a black box and trust the maintainers to do the right 
thing. I've been battling with it all for a while and most of the 
time regret every having started :-)

-- 
Alan McKinnon
alan at linuxholdings dot co dot za
+27 82, double three seven, one nine three five




More information about the ubuntu-users mailing list