handling dependencies

Ewan Mac Mahon ewan at macmahon.me.uk
Sun Jun 25 01:15:49 UTC 2006


On Fri, Jun 23, 2006 at 11:50:39AM -0700, maxim wexler wrote:
> I tried doing this:
> 
> booyah at ubuntu:~$ sudo dpkg -i D*/gpsim*

Hmm - not using apt? Why not?

> Selecting previously deselected package gpsim.
> (Reading database ... 64928 files and directories
> currently installed.)
> Unpacking gpsim (from .../gpsim_0.20.14-7.3_i386.deb)
> ...
So - that's the version of gpsim that's in Dapper....

> dpkg: dependency problems prevent configuration of
> gpsim:
>  gpsim depends on exdbm (>= 0.0.0-1); however:
>   Package exdbm is not installed.
>  gpsim depends on libc6 (>= 2.3.6-6); however:
>   Version of libc6 on system is
> 2.3.5-1ubuntu12.5.10.1.

... and the version of libc6 that's in Breezy...

> W: You may want to run apt-get update to correct these
> problems
> E: Unmet dependencies. Try 'apt-get -f install' with
> no packages (or specify a solution).
> booyah at ubuntu:~$
> 
> And when I tried apt-get -f install it just asks for
> permission to remove a partially installed version of
> the pkg, gpsim. Which I did to no avail.
> 
> What do I do now, please?
>
I'm not sure this'll work, but try explicitly removing gpsim with
'apt-get remove gpsim', then try the 'apt-get -f install' to fix up any
remaining damage. Also get a net connection (can you?) and apt-get
update, then apt-get install gpsim to get the Breezy version.

Also, try to work out how you've got into this state of mixing Breezy
and Dapper packages - this may not be the only problem.

Ewan

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20060625/db6e7a36/attachment.pgp>


More information about the ubuntu-users mailing list