Playing a DVD

Adam D emlists at
Thu Jun 22 19:29:37 UTC 2006

Henk Koster wrote:
> On Thu, 22 Jun 2006 02:26:46 -0700, Adam D wrote:
>> I hope it is ok to jump onto the thread?
>> I have a new AMD64 and have not been able to play commercial DVDs.  I see the very beginning video and when the encrypted part starts up.. xine quites on me.  I took the advise and when to the link up above and followed all the instructions.  However when it got to this section I am dead in the water.
>>       Installing libdvdcss2
>>             Applies to the AMD64 architecture only:
>>                   The script will compile the libdvdcss2 library for you instead of downloading a prebuilt binary. Make sure you install the debhelper, build-essential and fakeroot packages first. Then issue the command
>>                   sudo /usr/share/doc/libdvdread3/examples/
>> Since I have AMD64 I ran the above script with all the proper packages installed above I get these errors:
>> <snip>
> It worked just fine in my case... In addition to the packages
> mentioned, I also always install libtool, autoconf and automake1.9.
> Why don't you install those as well, and see how it goes.

All installed and I still have the same errors.

looking at just the ./configure output when I cd into /tmp/dvd/libdvdcss-1.2.5 I  get this:


checking whether -lc should be explicitly linked in... no
creating libtool
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking for size_t... yes
checking for unistd.h... (cached) yes
checking sys/param.h usability... yes
checking sys/param.h presence... yes
checking for sys/param.h... yes
checking limits.h usability... yes
checking limits.h presence... yes
checking for limits.h... yes
checking windows.h usability... no
checking windows.h presence... no
checking for windows.h... no
checking sys/ioctl.h usability... yes
checking sys/ioctl.h presence... yes
checking for sys/ioctl.h... yes
checking sys/cdio.h usability... no
checking sys/cdio.h presence... no
checking for sys/cdio.h... no
checking sys/dvdio.h usability... no
checking sys/dvdio.h presence... no
checking for sys/dvdio.h... no
checking linux/cdrom.h usability... yes
checking linux/cdrom.h presence... yes
checking for linux/cdrom.h... yes
checking dvd.h usability... no
checking dvd.h presence... no
checking for dvd.h... no
checking /sys/dev/scsi/scsi_ioctl.h usability... no
checking /sys/dev/scsi/scsi_ioctl.h presence... no
checking for /sys/dev/scsi/scsi_ioctl.h... no
checking sys/scsi/scsi_types.h usability... no
checking sys/scsi/scsi_types.h presence... no
checking for sys/scsi/scsi_types.h... no
checking sys/scsi.h usability... no
checking sys/scsi.h presence... no
checking for sys/scsi.h... no
checking IOKit/storage/IODVDMediaBSDClient.h usability... no
checking IOKit/storage/IODVDMediaBSDClient.h presence... no
checking for IOKit/storage/IODVDMediaBSDClient.h... no

A bunch of 'no's and when looking into my /sys I clearly do not have a /sys/dev directory.  My /sys looks like this:

block/  bus/  class/  devices/  firmware/  fs/  kernel/  module/  power/

and even if I do 'make' I get the same errors as well


More information about the ubuntu-users mailing list