Dapper, Canon and Turboprint

Tony Arnold tony.arnold at manchester.ac.uk
Thu Jun 15 14:04:42 UTC 2006


On Thu, 2006-06-15 at 08:14 -0500, Bob Mandel wrote:
> On Wed, 2006-06-14 at 14:46 +0100, Tony Arnold wrote:
> > I've upgraded my home machine from Breezy to Dapper and I have
> > Turboprint installed to drive my Canon IP-5000 printer. Last night,
> > printing seemed to stop working and I'm trying to figure out why.
> > 
> > I've seen a number of confusing messages and symptoms and then ran out
> > of time diagnosing this last night, so details are sketchy at the
> > moment. I believe I saw a message about an authentication certificate
> > being missing. CUPS also seemed to think the printer was a network
> > printer when in fact it is a USB printer. I've also seen syslog messages
> > saying failed to open /var/log/cups/error_log
> I was hoping someone who could do a better job would respond but I will
> share my experience. After upgrading my HP laserjet (parallel port)
> worked fine with turboprint but my usb canon i850 would not.
> First of all turboprint has an update for dapper - get that if you
> haven't (although I used the new version from the beginning so for as
> far as I know it could be the problem).

Yes, I found this and installed it. Printing seems to be OK now.

> Then I reinstalled cups.
> Then in turboprint xtpsetup I changed the device from /dev/usb/lp0 which
> had always worked in breezy to usb://Canon/i850.
> This got the printer working.

Curiously, the printer device was set to ipp:usb://Canon/ip5000 or some
such! Changed it to be similar to yours and that got it going.

> I have sometimes on restart had the problem you experienced of dapper's
> print manager seeing the printer as a network printer. When this
> happened I changed to local printer, use detected printer and it worked.
> Actually this has been sticking for awhile now and not reverting to
> network printer, I don't know why.

I'll keep an eye on it. I did try using 'detected printer', but only saw
the Canon printer once when trying this. Other times there was no
detected printer there!

> Hope this helps some,

Indeed it does. Many thanks.

Tony Arnold, IT Security Coordinator, University of Manchester,
IT Services Division, Kilburn Building, Oxford Road, Manchester M13 9PL.
T: +44 (0)161 275 6093, F: +44 (0)870 136 1004, M: +44 (0)773 330 0039
E: tony.arnold at manchester.ac.uk, H: http://www.man.ac.uk/Tony.Arnold

More information about the ubuntu-users mailing list