`aptitude install -f' unexpectedly shows many broken packages

Christoph Bier christoph.bier at web.de
Sun Jun 11 15:19:53 UTC 2006

Hi all,

some weeks ago I freshly installed Dapper Flight 6 on my laptop.
Today an upgrade of gdm failed (meanwhile I solved it). At first I
tried `aptitude install -f' and was very surprised about the long
output, you can find here:

There are many broken packages and packages with unmet dependencies.
Lots of packages are to be removed and others are not installable.
Quite strange IMO. Or is it normal? At least it doesn't seem to be
easy to resolve the problems. And why update-manager says
everything's ok?

Here are the entries of my sources.list:

deb http://de.archive.ubuntu.com/ubuntu dapper main restricted
deb-src http://de.archive.ubuntu.com/ubuntu dapper main restricted

deb http://de.archive.ubuntu.com/ubuntu dapper-updates main restricted
deb-src http://de.archive.ubuntu.com/ubuntu dapper-updates main

deb http://de.archive.ubuntu.com/ubuntu dapper-updates universe
deb-src http://de.archive.ubuntu.com/ubuntu dapper-updates universe

deb http://de.archive.ubuntu.com/ubuntu dapper-updates multiverse
deb-src http://de.archive.ubuntu.com/ubuntu dapper-updates multiverse

deb http://de.archive.ubuntu.com/ubuntu dapper universe
deb-src http://de.archive.ubuntu.com/ubuntu dapper universe

deb http://de.archive.ubuntu.com/ubuntu dapper multiverse
deb-src http://de.archive.ubuntu.com/ubuntu dapper multiverse

deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main

deb http://security.ubuntu.com/ubuntu dapper-security universe
deb-src http://security.ubuntu.com/ubuntu dapper-security universe

deb http://security.ubuntu.com/ubuntu dapper-security multiverse
deb-src http://security.ubuntu.com/ubuntu dapper-security multiverse

+++ Typografie-Regeln: http://www.zvisionwelt.de/typokurz.pdf (1.4)

More information about the ubuntu-users mailing list