how to debug broken hibernate?

Jaime Davila jdavila at
Tue Jun 6 16:37:11 UTC 2006

Eric Hanchrow wrote:
>>>>>> "Colin" == Colin Brace <cwb at> writes:
>     Colin> Hi all, I just installed Dapper on an Acer Aspire 5500Z
>     Colin> laptop.  Suspend works fine, but alas hibernate does not;
> I might as well pile on -- I have Dapper on a Dell Latitude C640, and
> neither hibernate nor suspend works.
> * When I try to hibernate, all that happens is: the disk churns for a
>   few seconds, the screen blanks, and then I see the "please enter
>   your password" prompt from the screen saver.
> * Suspending per se seems to work -- the screen goes dark, and the
>   various lights on the laptop turn off.  But when I press the power
>   button, and the machine comes back to life, the screen is garbled,
>   and the only cure I know of is a reboot.
> If it matters, the video card is
>         ATI Technologies, Inc. Radeon Mobility 9000 (M7 LW)

Could you provide the contents of /var/log/acpid? Linux should be 
writing into that file every time it detects an acpi event, like 
sleeping/hibernating requests.

I did a fresh install of dapper over the weekend on a thinkpad x40, and 
sleeping worked out of the box. That was not the case with breezy, but 
eventually I got it to work.

N.B. on sleeping. I am now using gnome as opposed to kde, which I was 
using under breezy. After updating from breezy to dapper (not a fresh 
install) I could not sleep under kde. Trying to fix this with backup 
files I hosed my installation (my fault completely for doing something 
silly). I then did a fresh install, and tried gnome, which worked. I'm 
not sure which desktop you're using.

About hibernating. I've never been able to hibernate to disk with a 
default installation, but have always been able to fix it. On my 
thinkpads (first a g40, now an x40) I have to do the following:
in file /boot/grub/menu.lst, look for the line that reads "# kopt". 
You'll use that line to pass boot parameters. In my case, that line 
reads "# kopt=root=/dev/hda1 ro nosplash quiet resume=/dev/hda5" .

The comment at the beginning is not a mistake. You don't need to 
uncomment that line.

root=/dev/hda1 indicates where my OS is.

resume=/dev/hda5 indicates where my swap partition is. You can find that 
by using the disk manager (applications -> system -> administration -> 

The nosplash line will make the bootup process not give you that nice 
ubuntu logo while booting. for some reason my laptops never come out of 
hibernation unless I add that.

I'm not sure what the "quiet" option does, but it has never hurt me.


Hope that helps,



Jaime J. Davila
Assistant Professor of Computer Science
Hampshire College
School of Cognitive Science
jdavila at hampshire dot edu

More information about the ubuntu-users mailing list