Dapper on a PowerBook G3?

Harold Johnson harold.johnson at gmail.com
Mon Jun 5 05:45:00 UTC 2006

I think I just figured it out!  On a hunch, I entered the string "
root=/dev/hda9" in BootX (in the "More Kernel Arguments:" field).  /dev/hda9
is the location and name of where my Ubuntu installation resides; you can
find this information through the console with the command "df" (or "df -h",
which prints a more human-readable readout).

So it's looks like Ubuntu is ready and rearin' to go on this ol' Wallstreet
again.  Now if only I can remember how to compile madwifi so that I can get
that D-Link wifi card going again...

So to wrap it up for posterity (for anyone looking for this information in
the future):

This series of posts documents my efforts at getting Ubuntu (Dapper)
installed on my PowerBook G3 (Wallstreet 2), an "OldWorld" Macintosh.  I
chose to install Ubuntu Server PPC Dapper on my machine since I only have a
2 gig hard drive on this baby.  The information I gathered reside on this


but anyone following those instructions may also want to read through my
posts in this thread, since I ran into a couple of problems the solution of
which weren't detailed in the set of instructions on the site linked above.

Good luck and have fun,

Harold J. Johnson

On 6/4/06, Harold Johnson <harold.johnson at gmail.com> wrote:
> Well, after reformatting my hard drive, making my Mac partition HFS and
> then running through my Dapper installation again, I was able to get past
> the stage I had been stuck on before -- I was able to mount my Mac OS
> partition and then copy vmlinux and initrd.gz to it.  Continuing with my
> installation, my PowerBook was reboot and BootX (the boot loader required
> for these OldWorld Macs) kicked into the installer again...
> ...or tried to, I should say, since the installer never got past the
> following line:
> "Begin. Waiting for root file system... ...
> Done.
> ALERT! does not exist. Dropping to a shell!"
> Then it dropped to the BusyBox shell and now I don't know what to do next.
> Any ideas?
> Thank you,
> Harold
> On 6/4/06, Harold Johnson <harold.johnson at gmail.com> wrote:
> >
> > Delving into the Ubuntu forums, I've already come across some
> > information that may be helpful for me in resolving my own installation
> > issue.  I had formatted my Mac partition as HFS Extended -- isn't that also
> > known as "HFS+"?  If so, I believe I may have mounted it as an HFS when
> > trying to copy to it, and I believe I should have mounted it as HFS+.
> > There's some way of doing this but I don't recall how at the moment...
> >
> > Harold
> >
> > On 6/4/06, Harold Johnson <harold.johnson at gmail.com > wrote:
> > >
> > >  Has anyone here made an installation of Dapper on a PowerBook G3
> > > yet?  I'm in the process of installing Dapper on my Wallstreet (that's the
> > > model of PowerBook G3); I've had Hoary, Warty, and Breezy previously
> > > installed on this system.
> > >
> > > I ran into a bit of trouble earlier today, but it looks to be minor.
> > > Anyway, I'll try again later and see how well I manage to get over this
> > > hurdle.  Installing Ubuntu (or any flavor of Linux) on a Wallstreet requires
> > > some amount of trickery, perhaps more than your usual installation.  For one
> > > thing, you need to partition your drive to allow your PowerBook to boot into
> > > the Mac OS, where it finds the Linux kernel and then proceeds to boot into
> > > Ubuntu.  The trick is getting your Linux kernel copied onto your
> > > Mac partition during your installation; there are various ways of doing
> > > this, but the method I tried this morning didn't work.  (I tried following
> > > some instructions I found on a website regarding installing Breezy on a
> > > Wallstreet, but the process of mounting the Mac partition from the
> > > command-line and copying the Linux kernel to it failed.)
> > >
> > > I'm looking forward to hearing any success stories; I will gladly post
> > > details once I find my own (success)!
> > >
> > > Sincerely,
> > > Harold J. Johnson
> > > http://somethingthathappened.com
> > >
> >
> >
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20060604/5cb00830/attachment.html>

More information about the ubuntu-users mailing list