pmount and floppies (was Re: writing to floppies possible as a user?)

Peter Garrett peter.garrett at
Mon Jan 30 09:55:19 UTC 2006

On Mon, 30 Jan 2006 19:06:11 +1100
Peter Garrett <peter.garrett at> wrote:

> > I've tried all of the tips and tricks suggested, but
> > nothing works in allowing write access in a GUI in Ubuntu Breezy. I
> > even tried one suggestion to chmod 777 the floppy drive and reboot,
> > it just does not work.
> > 
> > My /etc/fstab line for the floppy currently is as so:
> > 
> > /dev/fd0        /media/floppy0  vfat    rw,user,noauto  0       0
> > 
> > The above allows mounting but not writing.
> Try this in /etc/fstab  (it works for mounting and writing to floppy here
> on breezy):
> /dev/fd0        /media/floppy0  vfat    user,noauto,umask=022   0       0

just a follow-up on this:

The URL re-posted by Sven

shows a newer package;  0.9.6-1~breezy1

I just installed this ( sudo dpkg -i ) and it appears to solve the
problem, sort of...

With this line in /etc/fstab

/dev/fd0        /media/floppy0  vfat    user,noauto   0       0

writing and reading seem towork OK. I removed the umask setting with no
ill effects.

You still need the "vfat" option, as using "auto" gives an error .
For some reason, the first mounting attempt errored out, but a second
attempt worked - the ways of *nix are indeed mysterious to me...


(funny how my new .sig seems to fit this thread quite by accident ;-)

'If I ever saw an animated penguin with a speech bubble saying, 
"It looks like you're trying to edit fstab", 
I'd switch to BSD faster than a speeding Gentoo user.'
-- Paul Hudson

More information about the ubuntu-users mailing list