writing to floppies possible as a user?

Peter Garrett peter.garrett at optusnet.com.au
Mon Jan 30 08:06:11 UTC 2006

On Sun, 29 Jan 2006 19:18:04 -0800
"abetterturkey" <abetterturkey at hushmail.com> wrote:

> I've tried all of the tips and tricks suggested, but
> nothing works in allowing write access in a GUI in Ubuntu Breezy. I
> even tried one suggestion to chmod 777 the floppy drive and reboot,
> it just does not work.
> My /etc/fstab line for the floppy currently is as so:
> /dev/fd0        /media/floppy0  vfat    rw,user,noauto  0       0
> The above allows mounting but not writing.

Try this in /etc/fstab  (it works for mounting and writing to floppy here
on breezy):

/dev/fd0        /media/floppy0  vfat    user,noauto,umask=022   0       0

The trick here seemed to be the umask=022  Until I did that I had mounting
errors etc .  I just tried writing a couple of text files to the floppy by
dragging and dropping using nautilus, and it appears to be fine with the
fstab entry above.

If that doesn't work, try umask=000  ( the down side of that is that then
nautilus thinks all the files created are executable - 022 seems
preferable as it is the default umask for users)

Hope that works for you.

'If I ever saw an animated penguin with a speech bubble saying, 
"It looks like you're trying to edit fstab", 
I'd switch to BSD faster than a speeding Gentoo user.'
-- Paul Hudson

More information about the ubuntu-users mailing list