[dapper] rhythmbox and www.di.fm

Michael Bienia michael at vorlon.ping.de
Sat Jan 28 23:40:05 UTC 2006

On 2006-01-28 13:20:20 -0500, Darryl Clarke wrote:
> On 28/01/06, Michael Bienia <michael at vorlon.ping.de> wrote:
> > Hello,
> >
> > I've used rhythmbox to listen to some streams from di.fm.
> > But after the change from gstreamer 0.8 to gstreamer 0.10 I can't listen
> > to them anymore. When I press play rhythmbox returns nearly immediately
> > (without an error message). I've also tried to readd the streams but
> > with no other result.
> > Playing an mp3 file from the library works so I assume I've the
> > necessary gstreamer-plugins.
> > Playing the streams with beep-media-player also works.
> >
> > Can someone listen to the streams from di.fm with rhythmbox?
> According to the little red 'error' icon that shows up when I try to
> play it it says:
> "Cannot open source for reading"
> When I look at the .pls file and attempt to go to one of their feeds (
> ) directly, it gives me a 404.
> That error leads me to believe they are blocking streaming from
> unknown user agents (such as firefox, because streaming within it
> would be.. useless?)
> My guess is they're not allowing streaming to the gstreamer user
> agent, which is "gnome-vfs/2.12.1 neon/0.24.7" for gstreamer0.8
> (breezy) and "gnome-vfs/2.13.4 neon/0.25.4" for gstreamer 0.10
> (dapper)
> So, I don't think it's rhythmbox directly.  It also doesn't work on my
> breezy box using totem/rhythmbox (gstreamer 0.8).

You are correct that it isn't rhythmbox directly. I've done some
testing: if I use streamripper to relay the stream I can use both totem
and rhythmbox with http://localhost:8000 as stream and it works. If I
pass the original stream url directly to totem/rhythmbox it doesn't
work. I've also tried to call streamripper with the user-agent you
mentioned and it still works (but I haven't verified if streamripper
uses it).


More information about the ubuntu-users mailing list