Ubuntu/Kubuntu on Mac G5.

Larry Grover lgrover at zoominternet.net
Sun Jan 22 18:10:34 UTC 2006

Brian Durant wrote:
> BTW, I tried installing Ubuntu Dapper PPC Flight 3 on my G5. I have  
> switched the SATA drives so that OS X is now located in the lower  drive 
> bay. As I also had my Firewire external drive turned on and  attached so 
> that Ubuntu would register it as well. Therefore, the  drive I installed 
> Ubuntu on was registered as /sdb. Everything went  find until Ubuntu 
> tried to install yaboot. Here are the messages, in  the correct order, 
> but maybe not total content as I had to write it  on a piece of paper 
> from tty3:

Unless you were planning to install onto the firewire drive, there was 
no reason to have it connected during the Dapper install.  You don't 
need to "register" the firewire drive during the install in order to use 
it later -- firewire drives work fine as hotpluggable devices under linux.

I'm confused about which drive is what:  was the firewire drive assigned 
to sda? is sdc the original OSX system drive? is sdb the drive you are 
trying to install Ubuntu onto (along with the FAT32 and HFS+ partitions 
you mentioned in previous messages)?

> "Failed to install boot loader."
> "Please check system log or the output of the third console (tty3)"
> [2075.240927] ioct132(nvsetenv:4417): Unknown cmd fd(7) cmd(20007043)
> {` ´} arg(00000000) on /dev/nvran
> mkofboot: Finding OpenFirmware device path to `/dev/sdb2´...
> mkofboot: Finding OpenFirmware device path to `/dev/sdc3´
> ofpath: Driver: sg is not supported
> mkofboot:  Unable to determine OpenFirmware path for macosx=/dev/sdc3
> mkofboot:  Try specifying the real OpenFirmware path for macosx=/dev/ 
> sdc3 in /etc/yaboot.conf
> mkofboot:  Failed with exit status 1

I'm afraid I don't understand yaboot well enough to explain the error 
you got.  Perhaps having the firewire drive attached caused a problem?

Was sdc3 the partition housing your OSX system?  What is supposed to be 
in sdb2, the / directory of your linux system?

> I tried to reinstall the installer 2 more times with the same result,  
> while inside the install procedure, with the same result. Then I  
> continued with the install procedure and received the following message:
> "boot manuallty with the /boot/vmlinux kernel on partition /dev/sdb3  
> and root=/dev/sdb3 passed as a kernel argument."

If yaboot is correctly installed, when you boot the system you will get 
a plain text prompt asking whether you want to boot OSX, linux or from 
CDROM.  If you select linux, then you get a second plain text prompt. 
At the second plain text prompt, hit the "tab" key once, and you will 
get a listing of the kernels which are installed and available to boot 
from.  I think the default kernel is labelled "Linux".  You can pass 
arguments to the kernel from this second text prompt.  For example, by 

Linux root=/dev/sdb3

and then hitting the enter key.

If yaboot did not get installed properly, then you won't be able to do 
this.  I believe you can still get into your linux partition and boot 
the system by booting into open firmware (a shell-like interface that 
accepts a variety of rather cryptic commands).  You can boot into open 
firmware by holding down the command-option-O-F keys when you boot.  I 
don't know open firmware well enough to tell you how to boot your linux 
partition, however.  :(

You may also be able to boot from your linux partition if you boot while 
holding down the option key.  After a few minutes you should get a 
graphical window which lets you select the boot device.

> So, the question is where do I go from here? I imagine I could boot  
> from the Ubuntu Dapper PPC Flight 3 live-CD and go into etc/ yaboot.conf 
> which should reside on /dev/sdb2, correct? But what else  do I need to 
> do? Remember, I am a newbie. I would want yaboot to  default to OS X, 
> but to be able to boot into Ubuntu.

I'm not sure if Ubuntu sets OSX up as default or not (I think not), but 
it's easy enough to set it up yourself (basically, you edit the 
yaboot.conf file, in /etc, and then run the ybin program).  But I 
suggest getting you dual booting systems both installed correctly first, 
and then worry about this issue later.

> Lastly, I now get prompted when OS X has started up about my Ubuntu  
> install HD not being able to be read by OS X.

OSX can't read ext2/3 filesystems (nor as far as I know, reiserfs, xfs, 
etc).  There is third party support for ext2/3:
but as far as I know, it doesn't work under OSX 10.4 yet (just 10.3 and 

> I hope you have some ideas :-)

I'm sure you could fix things by a less drastic method, but unless you 
get better ideas from someone else, I would suggest you try reinstalling 
Dapper, but this time *don't attach the firewire drive*.  Also, be sure 
you have your internal hard drives in the order you want them (sda, 
sdb), and be sure you know the drive/partition where your OSX system is 
and where the /  directory of your linux system will be.  I haven't 
installed yaboot on dual drive system, so I'm not sure if it needs to be 
on the first drive (sda) or not.


More information about the ubuntu-users mailing list