Can't boot a second HDD on slave [Solved]

J.Markoll j.markoll at free.fr
Sun Jan 22 15:05:10 UTC 2006


J.Markoll a écrit :
> Hello,
> When booting I get Grub Error 21: can't find the HDD.
> 
> The HDD's are IDE, the one that boots is Hda on master
> the second one is just behind. The Grub (and kernel)that boots is in
> /boot/grub/menu.lst inside the / partition.
> 
> I've got:
> =-=-=-==-=-=
> The text bloc I added in /boot/grub/menu.lst for this second HDD:
> 
> title        Edubuntu, kernel 2.6.12-9-386
> root        (hd1,1)
> kernel        /boot/vmlinuz-2.6.12-9-386 root=/dev/hdb2 ro quiet
> initrd        /boot/initrd.img-2.6.12-9-386
> savedefault
> boot
> 
> Content of the 'sudo cfdisk /dev/hdb'
> 
> 
>       hdb1                                 Primaire        Linux swap / 
> Solaris                                403,04
>       hdb2               Amorce            Primaire        Linux ext3 
>               [/]                      3997,49
>       hdb3                                 Primaire        Linux ext3 
>                                       35615,47
> 
> 
> Content of the device.map (added the second line after a first reboot)
> 
> $ cat /boot/grub/device.map
> (hd0)   /dev/hda
> (hd1)   /dev/hdb
> =-=-=-==-=-=
> 
> do someone see what I could have  mistaken or forgotten ?
I went on the #ubuntu chan where someone gave me the idea to check the 
settings in the BIOS. The slave had to be enabled. That was the trick.
Thus, the people on the chan are also of a great help (I use 
http://pastebin.com to give the outputs and give the Url on the chan)
Best greetings, Joyce Markoll.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 256 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20060122/d60b415a/attachment.pgp>


More information about the ubuntu-users mailing list