grub does nothing

Thomas Beckett thomas.beckett at
Sun Jan 8 03:07:08 UTC 2006

> So it's a laptop ?

No, this is a desktop

> > Can anybody help? I have been trying to fix this for the last 10 hours!
> > I think I want to cry :(
> Please don't. A few questions and a few suggestions.
> Suggestions : boot a live CD and try to see what's in it's belly.
> /boot/grub/menu.lst (my favorite but possibly not the one that will fit)
> and see what is written precisely in there.

booted live cd and menu.lst is correct. It specifies root as on the
right disk and the kernel root is correct on /dev/hdb1

> Question : what was working fine on this machine preceedingly and for
> how long ? is it the right hdd indicated in this configuration ? I see
> root(hd1,0) which looks to me like a first partition on a secondary hdd.
see above

> Do you have Grub on the first hdd Master Boot Record actually ?
Grub is on the primary master boot record and works fine in booting windows.

> Do you have the boot partition apart ? hem what else ? is it horrible if
> you needed reinstalling Dapper, in the worse case ?
I have reinstalled Dapper about 10 times now with different configurations

I tried installing to a partition on the first disk - didnt fix it, same problem
I tried reinstalling on the second disk - same problem

These are two new Maxtor 40GB disks and havent had anything on them
previously (except winXP which is still on a partition on the first
one) so I thought I would try my old disks which have sucessfully ran
everyting from Warty and Hoary to QNX, windows and Solaris. Again Grub
didnt do anything after displaying the boot command-list and sat there
blinking at me.

I have now installed Breezy on the second new disk and it works fine,
Grub hapily loads the kernel and boots the os.

I will now try dist-upgrading to Dapper and see if when it upgrades
Grub the same thing happens.

I no longer wish to cry, but eating my own arm is looking increasingly apealing!


More information about the ubuntu-users mailing list