apt: Apt SEGVs on most operations

Samium Gromoff _deepfire at feelingofgreen.ru
Tue Dec 19 17:09:08 UTC 2006


Package: apt
Version: 0.6.46.4ubuntu4
Severity: critical
Justification: breaks the whole system

root at betelheise:/home/deepfire # apt-get install epiphany
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Segmentation fault
root at betelheise:/home/deepfire # apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Segmentation fault

A strace of dying apt is attached.

-- Package-specific info:

-- apt-config dump --

APT "";
APT::Architecture "i386";
APT::Build-Essential "";
APT::Build-Essential:: "build-essential";
APT::Install-Recommends "0";
APT::Install-Suggests "0";
APT::NeverAutoRemove "";
APT::NeverAutoRemove:: "^linux-image.*";
APT::NeverAutoRemove:: "^linux-restricted-modules.*";
APT::Install-Recommends-Section "metapackages";
APT::Periodic "";
APT::Periodic::Update-Package-Lists "1";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::AutocleanInterval "0";
APT::Archives "";
APT::Archives::MaxAge "30";
APT::Archives::MinAge "2";
APT::Archives::MaxSize "500";
APT::Acquire "";
APT::Acquire::Translation "environment";
Dir "/";
Dir::State "var/lib/apt/";
Dir::State::lists "lists/";
Dir::State::cdroms "cdroms.list";
Dir::State::userstatus "status.user";
Dir::State::status "/var/lib/dpkg/status";
Dir::Cache "var/cache/apt/";
Dir::Cache::archives "archives/";
Dir::Cache::srcpkgcache "srcpkgcache.bin";
Dir::Cache::pkgcache "pkgcache.bin";
Dir::Etc "etc/apt/";
Dir::Etc::sourcelist "sources.list";
Dir::Etc::sourceparts "sources.list.d";
Dir::Etc::vendorlist "vendors.list";
Dir::Etc::vendorparts "vendors.list.d";
Dir::Etc::main "apt.conf";
Dir::Etc::parts "apt.conf.d";
Dir::Etc::preferences "preferences";
Dir::Bin "";
Dir::Bin::methods "/usr/lib/apt/methods";
Dir::Bin::dpkg "/usr/bin/dpkg";
aptitude "";
aptitude::Keep-Unused-Pattern "^linux-image.*$ | ^linux-restricted-modules.*$";
Unattended-Upgrade "";
Unattended-Upgrade::Allowed-Origins "";
Unattended-Upgrade::Allowed-Origins:: "Ubuntu feisty-security";
DPkg "";
DPkg::Pre-Install-Pkgs "";
DPkg::Pre-Install-Pkgs:: "/usr/sbin/dpkg-preconfigure --apt || true";
DPkg::Post-Invoke "";
DPkg::Post-Invoke:: "if [ -d /var/lib/update-notifier ]; then  touch /var/lib/update-notifier/dpkg-run-stamp; fi";

-- /etc/apt/preferences --

Package: libnspr4
Pin: version 1.7.12-1ubuntu2
Pin-Priority: 1002

-- /etc/apt/sources.list --

deb http://ru.archive.ubuntu.com/ubuntu feisty  main restricted universe multiverse
deb http://people.ubuntu.com/~pitti/ddebs edgy main universe

deb http://wine.budgetdedicated.com/apt edgy main
deb http://aszt.inf.elte.hu/~lorentey/mirror/apt unstable multi-tty
deb http://people.debian.org/~pvaneynd/cl-dapper-packages ./
# deb http://eros.vlo.gda.pl/~szuwarek/files/linux/bmpx/dapper ./


-- System Information:
Debian Release: testing/unstable
  APT prefers feisty
  APT policy: (500, 'feisty')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-mm3-betelheise
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages apt depends on:
ii  libc6                  2.5-0ubuntu5      GNU C Library: Shared libraries
ii  libgcc1                1:4.1.1-21ubuntu2 GCC support library
ii  libstdc++6             4.1.1-21ubuntu2   The GNU Standard C++ Library v3

Versions of packages apt recommends:
ii  ubuntu-keyring              2005.01.12.1 GnuPG keys of the Ubuntu archive

-- no debconf information
-------------- next part --------------
tla tree-lint | egrep ""\|e -v -x | grep apparent -v | (
	read str;
	while test ! -z "$str"; do
		tla add "$str"
		read str;
	done
)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: dump
Type: text/x-c
Size: 21509 bytes
Desc: not available
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20061219/8d16b925/attachment.bin>


More information about the ubuntu-users mailing list