Latest Dapper update won't let me administrate CUPS

Dave M G martin at
Wed Apr 26 08:04:33 UTC 2006

Ubuntu Users,

In the latest batch of Dapper updates, there was not only a bunch of 
CUPS related packages, but unlike other times, it asked me if I wanted 
to replace my cupsd.conf file.

Well, since my printer was already not working, I figured I'd let it 
install a new cups.conf, and see what came of it. Besides, it seemed to 
me that changing the cupsd.conf file might be symptomatic of more 
changes within CUPS.

Well, things are a little different now. If I go to the CUPS web 
interface, and select to "Manage Printers", my Canon printer is shown 
has having stopped. It's never started out as "stopped" before.

If I click the green "Start Printer" button, I get a window asking me 
for my administrative username and password.

And this is where I hit a wall. It won't accept any username and 
password combination I can think of. I've tried "root", "dave", "admin" 
for usernames, and I've tried my account's password, a few other 
passwords I usually use for these purposes, and leaving the field blank. 

Okay, so I hit the ol' web trail and look for solutions to figure out 
what the password is, or how to reset it. In the former case I came up 
with nothing. But in the latter, I got this command:
dave at homebase:~$ sudo lppasswd -a
Enter password:
Enter password again:

But that didn't work, at least not with "root", "admin", or "dave" as 
the username.

Another web page said I should comment out "AuthType Basic" and 
"AuthClass System " from cupsd.conf.  There was no "AuthClass System", 
but there were two instances of "AuthType Basic" which I commented out.
Still nothing.

So here I am. What do I do to get or reset the correct login information 
for administrating CUPS?

Dave M G

More information about the ubuntu-users mailing list