Syslog restart makes slapd hang ? (or vice versa..)

John Affleck lists+ubuntu-users at
Thu Apr 20 13:32:54 UTC 2006

I recently moved from NIS to LDAP, in order to get the samba domain
controller goodness.  Everything works fine for a couple of days, then
slapd appears to hang and I can't authenticate anyone.  If I'm lucky
and planned ahead, I could ctrl-alt-del and reboot, otherwise it was
hard reset time.

I finally got chance to see what was going on this morning.  I gdb'd
the slapd process and found it stuck in what appears to be a send to
syslog path.  I tried restarting slapd, but it would hang at startup. 
So I restarted syslog and then everything worked just fine.

This appears to happen every time logrotate runs.  Short of putting a
cron job to restart them both every day, what else can I do to either
a) figure out what the issue is, or b) make the problem go away.  I
assume it's some race between user lookup in syslog and slapd not
being able to write logs, but that's as far as I can get...


	John A.

More information about the ubuntu-users mailing list