strange problems with Internet connection

Lutzer M.Lutzer at
Sun Apr 16 08:32:00 UTC 2006

Is this bug filed in launchpad? Keith reports the bug does still exist
in Dapper...

Do you know any other thread which discusses the same issue?

Michael M. schrieb:
> Keith Richie wrote:
>> I have been plagued with these same problems with Ubuntu. What I did
>> to fix it was set up my connection with a static IP. Depending on your
>> router, set your IP as something like
>> <>, also set the gateway as your router's IP. I've
>> tried disabling IPv6 system wide, in Firefox...... none of that solved
>> the problem. I thought it was a flaky DNS from my ISP, so I tried
>> several different, no luck. Once I set a static IP everything was
>> solved. Upon a fresh install of Dapper plagued with the exact same
>> network problems. So I did the same, set up a static IP, but left IPv6
>> enabled, zero problems.
>> I wonder exactly what the problem is though? I don't have these issues
>> with CentOS, nor Windows. It doesn't matter if I use a Netgear or
>> Linksys router, or if I connect directly to the cable modem. Unless I
>> specify a static IP, my connection is slow and intermittent.
>> Reading this list, and the forums it seems to be a common enough
>> problem though, that is always passed on to the fault of the router. I
>> don't believe this is it. If it was, people would be having the same
>> issues inside Windows. Windows XP and 2000 both have IPv6 enabled by
>> default. Perhaps the DHCP client is bugged? Who knows.
> I think you're correct.  I don't believe it is the fault of the router. 
> I have had the same issues with IPv6 in both Ubuntu and Debian.  But I
> also have an iMac connected to the same modem/router (in my case, my
> ISP-provided modem is also a router) and I have no connectivity issues
> under OS X, which has IPv6 enabled.  I can try to load a website with
> Firefox, watch it time-out; scoot over to my iMac and load the same
> website with Firefox with no problem.
> I've also seen people blame Firefox and Mozilla, but the problem goes
> well beyond Mozilla and other Gecko browsers.  Even w3m fails for me,
> unless I explicitly invoke the "-4" option, which is to use IPv4 only.
> It's also not an across-the-board Linux issue, though I have seen people
> using other distros have some similar problems.  But it is particularly
> bad with Debian and Ubuntu, and I suppose, other Debian-based distros. 
> Arch Linux works just fine for me, with IPv6 enabled.
> But I did recently make a discovery that I haven't had time to pursue. 
> After I reinstalled Debian recently, it started working out of the box,
> with no disabling of IPv6 necessary.  I wasn't sure what caused this,
> but I found that when I installed the full gnome metapackage, the
> problem returned.  I uninstalled the gnome package and left just the
> gnome-desktop-environment metapackage installed, and the problem went
> away.  Looking at the differences between the packages, it seems like
> avahi is the most likely culprit.  Under Debian, it gets installed with
> gnome but not with gnome-desktop-environment; and it is directly related
> to DNS configuration and IPv6 in particular.  I haven't even had a
> chance to check how this package is installed in Ubuntu as I've been
> distracted by some family issues and haven't had time to futz around. 
> At this point, I'll probably just wait for Dapper.  But anyone else
> having these problems might want to take a look at what avahi does.

More information about the ubuntu-users mailing list