Problem installing phpmyadmin with dapper.

Patrick nawty at
Mon Apr 10 16:32:44 UTC 2006


I'm trying to install phpmyadmin, and i've got the php5 build
installed, yet it still seems to want to install php4 etc. surely if
it says :

Depends: php5 | php5-cgi | php4 | php4-cgi, php5-mysql | php5-mysqli |
php4-mysql, apache2 | httpd, debconf (>= 0.2.26) | debconf-2.0, ucf
(>= 0.8)

that means, i can have php5 installed :

i A libapache2-mod-php5             - server-side, HTML-embedded scripting langu
i   php5                            - server-side, HTML-embedded scripting langu

i pass that dependancy, so it shouldn't try install php4 from that dep.

and then if i have php5-mysql, i should pass the next dep :

i   php5-mysql                      - MySQL module for php5

the next dep's seem to be fine :

i   apache2                         - next generation, scalable, extendable web

so why's it trying to install php4...

Any ideas?

patrick <at> eefy <dot> net

More information about the ubuntu-users mailing list