Loading midi soundfonts on startup

'Forum Post ulist at gs1.ubuntuforums.org
Tue Sep 27 10:40:51 UTC 2005

>That's true! For some time now, "modprobe" no longer accepts the

>"post-install" directive! I didn't know that until you mentioned it

>I went through the manual page for "modprobe.conf" to know that!


Cool, at least we're both getting something out of my problem :)

>Apparently, the new way to do the "post-install" thing is like this

>following is one long line):

>install snd-emu10k1-synth --ignore-install snd-emu10k1-synth &&
>/lib/alsa/modprobe-post-install snd-emu10k1-synth

>Now, create a file named, say, "snd-emu10k1-synth.post-install" in

>"/etc/alsa/modprobe-post-install.d" and put in it:



># modprobe post-install script for alsa (snd-emu10k1-synth)

>/usr/bin/asfxload /etc/midi/8mbgmsfx.sf2

>Change it's owner to "root:root" and permission to "rwxr-xr-x" by

>running (the following are two lines):

>sudo chown root:root

>sudo chmod 0755

I have tried your suggestions, following your instruction closely but
the above did not work. In fact none of the midi worked any longer.
Even activating the soundfont manually did not work any longer.
Rosegarden did not work either. But I didn't get any further errors at

However, when I deleted those two files 'etc/modprobe.d/soundfont'  and
'/etc/alsa/modprobe-post-install.d/snd-emu10k1-synth.post-install' all
was back to normal.

I have checked the paths of those files and the soundfont name ....
they are correct. I have tried your suggestion a few times to make sure
I got it all right - but same outcome every time. Although I must admit
that I don't really know what all that stuff means, so I'm in no
position to spot mistakes.

>All the above is okay, however, did you try without them? In hoary,

>everything should be detected automatically and loaded accordingly

>(except for the "lp" module). This is not important, just a thought.

You're right - it all worked even when all those lines are commented

>Where did you learned it from?

I followed some of the advice on this page:


It's probably ancient (2002 according to footer).

So I'm still stuck. I would love more help if you have time. 

Thanks again


More information about the ubuntu-users mailing list