Installing MPlayer

Peter Garrett peter.garrett at optusnet.com.au
Wed Sep 21 19:20:18 BST 2005


On Wed, 21 Sep 2005 18:38:57 +0100 (BST)
Lyndy Joseph <lyndyjoseph at yahoo.co.uk> wrote:

> I have tried several times to install MPlayer and came
> up with this error:
> E: Could not get lock /var/lib/dpkg/lock - open (11
> Resource temporarily unavailable)
> E: Unable to lock the administration directory
> (/var/lib/dpkg/), is another process using it?

Lyndy -

The above message usually means you have two "instances" of the installation system running.
Most commonly this means you have "Synaptic/Kynaptic Package Manager" open and try to run another installation , say , from a terminal. So the solution is to close one of them - unless a download or installation is in progress, in which case you would wait for that to complete first, of course.

> Don't know what to do. Need help please. I type (sudo
> -s -H) in Konsole but still no joy. Can someone walk
> me through PLEASE?

Some of this you may know:

1. You don't need to type sudo -s -H to get a root shell -  sudo -i   will achieve the sme purpose, but normally it's better to just type

sudo <your command here>

2. You mention Konsole so I'm assuming you have Kubuntu: in that case I believe Synaptic is not installed by default. Kynaptic is OK, but lacks some of the configurations available using Synaptic.
If you type in konsole

apt-cache search mplayer

you should see a list of alternative mplayer packages. This can be a bit confusing - the one to install is the one for your architecture, which you can determine by typing

uname -m

3. If you see no listing of mplayer packages this means that you have not enabled the multiverse repository. I suggest enabling both the "universe" and "multiverse" . This is explained on this page:

https://wiki.ubuntu.com/AddingRepositoriesHowto

I suggest , though , that it might be just as easy to open your /etc/apt/sources.list  file either with

sudo kate /etc/apt/sources.list  (for Kubuntu)                 or

sudo gedit /etc/apt/sources.list (for Ubuntu)

"uncomment" the lines starting with "deb" and "src" in this file. (that is, remove the # mark in front of each - the # mark makes the line into a comment which is ignored by the program). DON'T remove the # mark from any other lines in the file.

To add multiverse , type the word "multiverse" (without quotes) at the end of each "universe" line.

4. Save the file. Now run

sudo apt-get update

then you will be able to install an mplayer package as outlined above, using the package manager or a command like

sudo apt-get install mplayer-586   (this will depend on your architecture)

If this is confusing, or you are unsure how to proceed, reply to the list with your difficulties and give information about your "architecture" as above  ( output of the uname -m command), and what you did , step by step. Someone will be able to help, for sure.

Peter


-- 

Linux User #343161 




More information about the ubuntu-users mailing list