fetchmail stops working after upgrade to Breezy

Eamonn Sullivan eamonn.sullivan at gmail.com
Sun Sep 18 12:58:06 UTC 2005

On 18/09/05, Eamonn Sullivan <eamonn.sullivan at gmail.com> wrote:
> in fetchmailrc added an smtp option:
> smtp "smtp.blueyonder.co.uk"
> in /etc/postfix/main.cf added two options:
> relayhost = smtp.blueyonder.co.uk
> inet_interfaces = $myhostname, localhost
> And now it works. Thanks again.

Apologies for replying to myself, but I spoke too soon. The only mail
that arrives at my gmail address are messages sent locally (i.e., cron
and anacron messages and test email I send via /usr/bin/mail). Items
downloaded from my blueyonder account go to the bit bucket.

Quick summary of the problem: 

1. I have a ".forward" file with just one line: 
eamonn.sullivan at gmail.com

2. I have a ".fetchmailrc" file with the following (password, username
changed to XXXXXX):

poll pop3.blueyonder.co.uk
        proto pop3
        user "XXXXXXXXXX"
        pass "XXXXXXXXXX"
        is esullivan
        no ssl
        smtp "smtp.blueyonder.co.uk"

3. My /etc/postfix/main.cf file looks like this: 

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no
# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h
# Uncomment the next line to use procmail for delivery
#mailbox_command = procmail -a "$EXTENSION"
alias_maps = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = localhost.localdomain, localhost.localdomain, localhost
mynetworks =
relayhost = smtp.blueyonder.co.uk
inet_interfaces = $myhostname, localhost
mailbox_size_limit = 0
recipient_delimiter = +
unknown_local_recipient_reject_code = 450
sendmail_path = /usr/sbin/sendmail

4. Problem: email appears to download correctly from blueyonder and
there aren't any error messages, but nothing arrives at gmail. There
must be something I'm missing. This all worked perfectly in Hoary and
has stopped working in Breezy. I suspect I changed a configuration
file and then allowed the config to be overwritten during

this works: 
$ mail eamonn.sullivan at gmail.com
Subject: test

The test email arrives in Gmail without problems. 

Can anyone spot what I'm missing?


More information about the ubuntu-users mailing list