Colony 4: wifi problems on HP laptop

Jimmie Houchin jhouchin at
Wed Sep 7 15:48:25 UTC 2005

An update.

I don't have any idea what is happening, but...

My eth0 has worked on this machine. So I was able to connect to the net
via cable to my router. Which is how I posted the message.

I have been updating 2-3 times a day hoping that an upate would come
thru which would fix whatever kept wifi from working. Nothing. :(

So this morning I restarted (it crashed overnight) and deciced to edit
the kernel boot parameters. I added no_apic to the line. And booted.

I tried the standard:
iwconfig wlan0 essid *****
dhclient wlan0

and it worked. Woohoo!

But it was a very unstable setup. It crashed in a matter of minutes. :(
So I restarted normally. And as per due diligence, I attempted my wifi.
And it worked. Woohoo!

I don't know why but I've changed nothing that I know of other than a
single startup of no_apic and successful wifi connection. Then it is
working on normal startup.

Now I do get lots of APIC errors in dmesg

I don't know what the deal is but it is up and running currently.


Jimmie Houchin wrote:
> I have just installed Ubuntu Colony 4 on my HP zv6131us laptop.
> Before this installed I had an uptodate Breezy install.
> I wanted to give the new CD and installer a try and see if any of the
> issues were resolved.
> Unfortunately no.
> At
> I post of my previous success in getting Ubuntu running on this machine.
> With the Colony 4 CD I still had to do it all over again.
> Unfortunately, the wifi isn't working. Ugh!
> I compiled the same ndiswrappers (and also the latest 1.3rc1).
> I compiled the exact same driver.
> Everything seems to be installed fine.
> ndiswrapper -l
> bcmwl5  driver present, hardware present
> iwconnfig
> wlan0     IEEE 802.11g  ESSID:"milagronet"
>           Mode:Managed  Frequency:2.442 GHz  Access Point: 00:13:10:E3:F2:FB
>           Bit Rate=54 Mb/s   Tx-Power:25 dBm
>           RTS thr:off   Fragment thr:off
>           Encryption key:off
>           Power Management:off
>           Link Quality:100/100  Signal level:-66 dBm  Noise level:-256 dBm
>           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
>           Tx excessive retries:0  Invalid misc:0   Missed beacon:0
> dhclient wlan0
> There is already a pid file /var/run/ with pid 0
> Internet Systems Consortium DHCP Client V3.0.2
> Copyright 2004 Internet Systems Consortium.
> All rights reserved.
> For info, please visit
> sit0: unknown hardware address type 776
> sit0: unknown hardware address type 776
> Listening on LPF/wlan0/00:90:4b:f5:96:b3
> Sending on   LPF/wlan0/00:90:4b:f5:96:b3
> Sending on   Socket/fallback
> DHCPDISCOVER on wlan0 to port 67 interval 3
> DHCPDISCOVER on wlan0 to port 67 interval 3
> DHCPDISCOVER on wlan0 to port 67 interval 4
> DHCPDISCOVER on wlan0 to port 67 interval 10
> DHCPDISCOVER on wlan0 to port 67 interval 21
> DHCPDISCOVER on wlan0 to port 67 interval 9
> DHCPDISCOVER on wlan0 to port 67 interval 11
> No DHCPOFFERS received.
> No working leases in persistent database - sleeping.
> /etc/network/interfaces  contains:
> auto wlan0
> iface wlan0 inet dhcp
> I do the same thing I've done successfully for the last month, but
> unsuccessfully.
> In a term window.
> sudo iwconfig wlan0 essid ******
> sudo dhclient wlan0
> I went from a working setup to a non-working setup in a matter of an
> hour or so.
> I hope I don't have to reinstall Colony2 and update, just to get my wifi
> working again.
> Any help greatly appreciated.
> Jimmie

More information about the ubuntu-users mailing list