No sound from RealPlayer [I've still a problem]

Michael Shergold michaelshergold at
Sun Oct 30 07:34:57 UTC 2005

All I get is "Can't init audio driver Alsasink - try another one"
and then no driver found(alsasink)'   ore something?
Where are these drivers to be found.. I'm running on an elderly Compaq 
Presario laptop.

----- Original Message ----- 
From: "Eamonn Sullivan" <eamonn.sullivan at>
To: "Ubuntu Help and User Discussions" <ubuntu-users at>
Sent: Saturday, October 29, 2005 7:37 AM
Subject: Re: No sound from RealPlayer [SOLVED]

On 28/10/05, Eamonn Sullivan <eamonn.sullivan at> wrote:
> Hi, here's odd one I can't solve:
> I'm using Breezy, dist-upgraded in stages from Warty. Sound works
> perfectly for every application except RealPlayer, and that only
> stopped working about a week ago. The only thing I did around then was
> to apt-get edubuntu-desktop (*huge* hit with my kids, btw, nice work)
> and then removed edubuntu-artwork (so that I can have the normal
> themes for the adults).
> I can't imagine how this managed to break RealPlayer and *just*
> RealPlayer, so I could be totally wrong here. All other sound events
> work fine: BMP player, VLC, etc.
> I've reinstalled RealPlayer (v10) from Real's Web site, tried playing
> with the settings in .asoundrc (then moved it out of the way), changed
> from ESD to Alsa and then back in Multimedia Settings -- all to no
> effect.
> Anyone have any ideas I can try? I miss my Radio 4 in the morning....
> -Eamonn

Just to document the solution to this problem, if it occurs to anyone
else: I needed to rerun gstreamer's registration:

$ gst-register-0.8

RealPlayer works fine now and I'm listening to Radio 4.


ubuntu-users mailing list
ubuntu-users at

No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.362 / Virus Database: 267.12.5/150 - Release Date: 27/10/2005

More information about the ubuntu-users mailing list