qparted issue: cannot split ntfs partition

Phillip Susi psusi at cfl.rr.com
Fri Oct 21 02:26:59 UTC 2005

If the laptop did not come with the setup/recover/whatever they call the 
cd these days that reinstalls windows cd, then they should send you one 
if you call and ask.  If your only concern is that some day you might 
want to put windows back, then that should solve it. 

If you really want to dual boot, then running ntfsresize should work 
fine.  I tried using gparted to resize my ntfs partition when I 
installed, but gparted aparently does not like my SATA fakeraid, so it 
also just sat there for a few seconds, and then did nothing without 
giving any kind of error message. 

I ended up using ntfsresize to do the shrink by hand.  At first it 
complained about inconsistencies on the disk, and told me to reboot into 
windows and force it to checkdisk.  After that, it resized the volume 
just fine.  When I deleted and recreated the partition, I did not see 
the option to put fdisk into sector mode, so it recreated the partition 
in the wrong location ( stupid cylinder mode ).  I ended up figuring it 
out, and recreated the partition right, and everything was fine.  Just 
make sure you use the 'u' command to put fdisk into sector mode and make 
sure when you recreate the partition that it starts on exactly the same 
sector that it originally did. 

A friend also recently installed and could not resize from the setupcd, 
so I walked him through using ntfsresize and it worked fine.  As for 
partition magic, I don't trust that thing further than I can throw it.  
I have used or seen it used 4 times in the past and all 4 times it 
completely ruined the disk. 

Samuel Thurston, III wrote:

> I just got a new dell laptop and was eager to install ubuntu in a 
> dual-boot configuration with windowsXP.  Since Dell no longer ships 
> install CD's and I don't want to lose any of the suspend/hibernate 
> functions of my laptop, I wanted to resize the NTFS partition to make 
> room for an Ubuntu partiton.  I was glad to see that on the new live 
> CD, qparted is part of the installed packages.  I opened it and tried 
> to split the main partition, still leaving plenty of space for the 
> hungry windows swap file and several gigs of application data.   I 
> rearranged the partition as I wanted and hit apply, and after roughly 
> 30 seconds of progress bar, the partition table redrew... exactly as 
> it was before. I'm a little lost as to where to go from here, I don't 
> really have the scratch to drop on a copy of Partition Magic, and 
> don't want to even if I did.  I tried running an appropriate 
> ntfsresize command with the options set to just show me what would 
> happen, not to actually do it, and it said everything went fine... I 
> am however, hesitant to use ntfsresize in a permanent way as it would 
> seem to have the potential to screw things up but good. any suggestions?
> TIA,
> Sam

More information about the ubuntu-users mailing list