QT locales and fonts

Andy Choens gunksta at gmail.com
Sat Oct 8 15:09:48 BST 2005


In my quest to get OpenOffice.org to open using the KDE theme I have
figured out that my problem has to do with my QT and locales.  When I
try to run OpenOffice from within KDE I get the following error.

I18N: X Window System doesn't support locale "en_US.UTF-8"
I18N: Operating system doesn't support locale "en_US"
I18N: X Window System doesn't support locale "C"
Qt: Locales not supported on X server
ERROR: ld.so: object '/usr/lib32/libpangohack.so.0.0' from LD_PRELOAD
cannot be preloaded: ignored.

OpenOffice will open, but it won't use the KDE theme.  It looks like
something out of windows 95.  It does try to ape the system colors. 
In contrast, when I open OpenOffice in XFCE, it uses the GTK theme
just fine.

KDE apps open without this kind of an error.  However, I was intrigued
when I found that Scribus exits with a similar error.  When I try to
start Scribus it tells me there are no suitable fonts on my system.

I have this gut feeling that these are the same problem, viewed
through different lenses.

I have tried to reconfigure locales, libqt3-mt, openoffice.org2, and
my xserver at one time or another.  I even added spanish to my system
and switched to it as my local language, but got the same error.  I
sortof know where my problem is, but I don't know what to do about it.

I started this new thread because I no longer think OpenOffice is
actually my problem.  I think it is merely a symptom.  Programs that
use QT directly seem to be having locale issues and thus won't start,
or won't use the QT/KDE theme.

--andy




More information about the ubuntu-users mailing list