recent kernels won't boot

Phil Cryer phil at
Tue Oct 4 16:45:29 UTC 2005

Add a 'me too' to this one, but only with the following kern:


I haven't put a bug in yet, but -8 works fine; have rolled back for now.


-----Original Message-----
From: Evan Martin <martine at>
To: ubuntu-users at
Date: Tue, 4 Oct 2005 09:42:14 -0700
Subject: recent kernels won't boot

I've been happily apt-get'ing upgrades for months now (since before
Breezy, if that helps), but recent kernels suddenly stopped working.

With these more recent kernels at startup, I get, after the "audit"
console message that occurs on regular boots:
  Unable to find volume group "hda2"
  ALERT! /dev/hda2 does not exist
and then I'm dropped to busybox.

2.6.10-5-686-smp -- ok
2.6.12-6-686-smp -- not ok
I could narrow that down more if you think it'll help.

I've seen a few others have seen a similar problem, like this fellow:
But they've all been lilo problems and I'm using grub

Some more data:
I haven't changed my grub configuration from the default menu.lst and
update-grub output.

I'm not using LVM, to my knowledge.  I did a pretty straightforward
install of Ubuntu when I first set up this computer, and unless it set something
up without my knowledge...

% cat /etc/fstab | grep -v '^#'
proc            /proc           proc        defaults            0       0
/dev/hda2       /               reiserfs    defaults,noatime    0       1
/dev/hdc        /media/cdrom0   udf,iso9660 ro,user,noauto      0       0

% cat /proc/cmdline
root=/dev/hda2 ro quiet splash

Some guesses about the problem:
- Maybe there's an assumption about your drive setup that was
introduced in a later kernel?
- The machine is a Shuttle "Zen XPC ST62K", which means it may have
some funky hardware, so maybe the new kernel dropped some module?

I'd file a bug, but I'm not sure what package I should file against.

ubuntu-users mailing list
ubuntu-users at

"You teach best what you most need to learn." - Richard Bach

More information about the ubuntu-users mailing list