printer setup problems

Sven Richter sveri-list at
Fri Nov 18 13:36:47 UTC 2005

Hello Winton,

On Thursday 17 November 2005 11:09, squareyes wrote:
> Sven Richter wrote
> >Maybe you can try the following:
> >
> >turn off printer
> >sudo /etc/init.d/cupsys stop
> >sudo rm /var/spool/cups/*
> >sudo rm /var/spool/cups/tmp/*
> >sudo /etc/init.d/cupsys start
> >turn on printer
> >
> >This often helped me about it.
> Hi Sven,
> done that. No action from printer.
> Just had it working fine on my old 166 with win98se
> to make sure printer isn't faulty.
Hm, weired, really weired.

> >Sometimes you need to download an extra ppd file.
> >But i know nothing about this specific printer.
According to the Log you don't need a ppd file,
you seem to have the correct one.

But, despite it you could try the ppd file
from here, just for going sure:
You also will find Information there for your

> As I said had this printer working with Hoary install, on
> old mother board. Replaced board and power supply, still worked.
> Could this be a bios prob, as new install was with new mother board?
Hm, I don't think so,
but Never say Never again ;-)
I heard from a cdrom drive which wouldn't
read as long as a printer is connected to lpt0.
This was in the early 90s, but this shows,
nothing is impossible.

> >Yes, turn on the debugging and paste some logs here ;-)
> >
> >sudo vim /etc/cups/cupsd.conf
> >search for "LogLevel info" and replace it
> >with "LogLevel debug"
> >(in vim you can fast search with /searchterm
> >try /debug in this case and you will be right there
> >you want to be.
> >In vim you can enter writing mode by pressing the i key,
> >after replacing info with debug press the escape key
> >and then press :wq Enter to quit and save)
> >sudo /etc/init.d/cupsys restart
> All done (with Gedit :-)
*fg why not

> >Then try to print something.
> >Afterwards have look at
> >/var/log/cups/error_log
> >to catch out the relevant information enter
> >cat /var/log/cups/error_log | grep "the time you tried to print"
> >for example cat /var/log/cups/error_log | grep "15:45"
> Log generated:  Thanks Sven
> squareyes at here:~$ cat /var/log/cups/error_log | grep "20:14"
[cut some logs]
> D [17/Nov/2005:20:14:04 +1030] [Job 3] 0 %%+ font
> (GnomeUni-BitstreamVeraSans-Ro man) cvn
> D [17/Nov/2005:20:14:04 +1030] [Job 3] 0 %%Page: 2 2
> D [17/Nov/2005:20:14:04 +1030] [Job 3] --> This document is DSC-conforming!
> D [17/Nov/2005:20:14:04 +1030] [Job 3] Job claims to be DSC-conforming,
> but "%%B eginProlog" was missing before first line with another
> "%%Begin..." comment (is this a TeX/LaTeX/dvips-generated PostScript
> file?). Assuming start of "Prolog" h ere.
This doesn't look normal, but i couldn't find some
useful Information about that failure, maybe you'll
find more.

[cut more logs]
> D [17/Nov/2005:20:14:04 +1030] [Job 3] foomatic-gswrapper: gs '-dBATCH'
> '-sIjsServer=hpijs' '-sDeviceManu facturer=HEWLETT-PACKARD'
> '-sDeviceModel=HP LaserJet' '-dDEVICEWIDTHPOINTS=595'
> '-dDEVICEHEIGHTPOINTS=842' '-dDuplex=false' '-r300'
> '-sIjsParams=Quality:Quality
> =0,Quality:ColorMode=0,Quality:MediaType=0,Quality:PenSet=0,PS:MediaPositio
>n=7' '-dIjsUseOutputFD' '-sOutputFile=/dev/fd/3' '/dev/fd/0' 3>&1 1>&2
This also could be a starting point, i never saw something
like this.
Why is the the outputfile /dev/fd/something?
I thought this is the place for the floppydisks.

Hm, at least i have to say i am shooting at black
holes. I hoped to find an obvious failure like
File ... is missing or something like that.
But there doesn't seem to be a real error.

I'd advice you to post the log and your description
to the Forums at
I hope they can be more helpfull as i was.
Maybe somebody else here can give another advice.

If you find out more, plz post it here, i would be interested
in an solution or something like this.

Sven Richter

More information about the ubuntu-users mailing list