relaying? was: Re: mailman doesn't receive mail?

Tim Frost timfrost at xtra.co.nz
Sun Nov 13 22:24:06 GMT 2005


The relaying error indicates that exim (and also postfix when you tried
that) doesn't recognise that the host names for the two lists
(www.derailleur.org, www.racesci.org) are local.  You need to add them
to the "local_domains" line in your configuration.  (Add the line near
the top of the main configuration file if it doesn't already exist):

  local_domains = www.derailleur.org www.racesci.org

List ALL host names, other than the canonical name of the host, that you
want to have treated as local. 

As I am not an exim expert, I can't comment about the other error
("pipe_transport unset in system_aliases router").



Good luck


Tim


On Fri, 2005-11-11 at 16:23 -0500, Matt Price wrote:
> On Fri, Nov 11, 2005 at 04:01:53PM -0500, Matt Price wrote:
> > Hi,
> > 
> > I'm trying hard to get mailman working on a ubuntu (breezy, 5.10)  server.  
> > 
> > I have now tried both postfix and exim4 and neither seems to work.
> > the situation:
> > 
> > - mailman service starts without error
> > - mailman web pages etc. all look good.
> > - mailman sends out subscription messages just fine
> > - BUT: nothing sent to the list addresses works at all.
> > 
> > as I said, this same situation seems to pertain whether I'm using
> > postfix or exim.  
> > 
> > This is on a server that hosts several domains, e.g.,
> > *.racesci.org
> > *.derailleur.org
> > 
> > I have tried 
> > - the vanilla setup, no ocnfiguration added
> > - the instructions in "README.Debian.gz"
> > - the instructions in "READMIN.[Postfix/Exim].gz
> > - the wiki.ubuntu.com mailman instructions (virtually idential to those in README.Exim.gz
> > 
> > anyone seen this before?  any suggestions? I have already "apt-get
> > remove --purge" various packages, but have yet to remove the list
> > archives (I have some lists inherited from another server, which ran
> > an earlier version of mailman on debian/sid.  But I don't see
> > thatthey'rethe problem...).
> > 
> > appreciate whateverh elp can be given!
> > 
> 
> starting to find some clues in the exim4 log:  I suspect it has
> something to do withthe multiple hostnames somehow.  Look at this
> (thought I'd bewst munge the addresses & such a bit):
> 
> 2005-11-11 16:12:10 exim 4.52 daemon started: pid=30795, -q30m,
> listening for SMTP on port 25 (IPv6 and IPv4)
> 2005-11-11 16:12:10 Start queue run: pid=30796
> 2005-11-11 16:12:10 1Eag78-0007tj-Ej == |/var/lib/mailman/mail/mailman
> post testlist <testlist at www.derailleur - dot - org> R=system_defer aliases
> (-30): pipe_transport unset in system_aliases router
> 2005-11-11 16:12:10 1EafoT-0007bG-RF == |/var/lib/mailman/mail/mailman
> post anothertest <anothertest at www.racesci - dot - org> R=system_aliases defer (-30): pipe_transport unset in system_aliases router
> 2005-11-11 16:12:10 End queue run: pid=30796
> 2005-11-11 16:13:28 H=tomts43-srv.bellnexxia.net [209.226.175.110]
> F=<ma44 - at -mail.derailleur - dot - org> rejected RCPT <ma44 - at -derailleur - dot - org>:
> relay not permitted
> 2005-11-11 16:13:28 H=tomts43-srv.bellnexxia.net [209.226.175.110]
> F=<> rejected RCPT <ma44 - at -mail.derailleur - dot - org>: relay not permitted
> 2005-11-11 16:14:10 H=tomts5.bellnexxia.net
> (tomts5-srv.bellnexxia.net) [209.226.175.25]
> F=<ma44 - at -mail.derailleur - dot - org> rejected RCPT <ma44 - at -racesci - dot - org>: relay not permitted
> 2005-11-11 16:14:10 H=tomts5.bellnexxia.net
> (tomts5-srv.bellnexxia.net) [209.226.175.25] F=<> rejected RCPT
> <ma44 - at -mail.derailleur - dot - org>: relay not permitted
> --------------------
> 2 kinds of errors here:
> 
> "relay not permitted" -- I think this might have been happening with
> postfix too.  Is this ane error that needs to be fixed in
> dpkg-reconfigure exim4-config?  I tried a couple of things, didn't
> seem to work.
> 
> "pipe_transport unset in system_aliases router" -- is this something I
> should set in /etc/exim4/conf.d/router/ somewhere? I confess the
> syntax of these files ocnfuses me.
> 
> anyway, I'm really baffled, but have some clues, not really quite sure
> what to do next.
> 
> matt
> 
> 
> > thanks,
> > 
> > matt
> >  
> > 
> > 
> > Matt Price	    matt.price at utoronto.ca
> > History Department, University of Toronto
> > (416) 978-2094
> > 
> > The following addresses are for you if you're an evil spambot:
> > zeus at derailleur.org aardvark at derailleur.org
> > 
> 
> -------------------------------------------
> Matt Price	    matt.price at utoronto.ca
> History Department, University of Toronto
> (416) 978-2094
> --------------------------------------------
> 
> The following addresses are for you if you're an evil spambot:
> zeus at derailleur.org aardvark at derailleur.org
> 





More information about the ubuntu-users mailing list