Not able to install flashplugin-nonfree - "libruby (>=1.6.7-3) but it is not installable"
lee_b at digitalunleashed.com
Sat Nov 12 20:32:15 UTC 2005
On Saturday 12 November 2005 20:03, Ari Torhamo wrote:
> I have a problem getting flashplugin-nonfree installed in Breezy. When I
> try to install it with Synaptic, I get
> Dependencies: libruby (>=1.6.7-3) but it is not installable
> The funny thing is that libruby1.8 is available in the repositories. I
> even tried to install it beforehand, but it didn't help. Does anyone
> know what's wrong here? Thanks :-)
I think ruby1.6 is incompatible with the newer ruby1.8 version.
Flashplugin-nonfree may have been made with the older version of ruby, which
probably doesn't have the same libraries available now for some reason. Just
a guess, though.
Anyway, you *might* have some luck if you run the following commands as root:
apt-get -b source flashplugin-nonfree
More information about the ubuntu-users