Can't uninstall broken packages on hoary system

ian ian at eugeneweb.com
Fri Nov 11 18:33:07 UTC 2005


David A' Rebel wrote:

>On Fri, 11 Nov 2005 21:11, ian wrote:
>  
>
>>I'm having a really great apt problem on hoary.
>>I have a bunch of webmin modules installed from universe, but webmin
>>itself isn't installed, so those packages are considered broken because
>>of the missing dependency.  However, I can't remove them or forceably
>>remove them using synaptic or any other method I've tried from man
>>apt-get because they have unsatisfied dependencies!   I'm just trying to
>>get rid of them all together because having them broken stops me from
>>using apt to install other packages.
>>
>>    
>>
> Have you tried removing them with sudo apt-get remove from a cli ?
>You could try something like sudo dpkg -l |grep webmin to see what comes up 
>and then try removing them with apr-get or with dpkg -r .
>
>
>
>  
>
yes, I've tried apt-get remove, I"ve tried forcing it, I've used remove
completely from within synaptic (not sure what the command line equiv is
for that) and it always gives me an error that there are broken
packages.  how do I forceably remove the packages without checking
dependancies or anything else?  I just want to delete all the files
associated with them and mark them uninstalled.

    --Ian




More information about the ubuntu-users mailing list