Please Help, I'm begging you: new Powerbook install problem 5.10

Larry Grover lgrover at
Wed Nov 9 14:04:11 UTC 2005

Steve Calvin wrote:
> Well, still no luck. It doesn't appear that any of the 'dev/
> [devices]', 'dev/scsi[devices] correspond to my optical drive, so
> the  Ubuntu install fails because of no 'common' cdrom.  So maybe
> this is  a kernel problem rather than a Ubuntu problem. I guess I
> have to wait  for an update then. I don't know how else to test
> this hypothesis,  anyone have Ubuntu, or any Linux, installed on
> the newest Powerbooks?
> steve


>>>> On 11/6/05, Steve Calvin <stevacon at> wrote:
>>>>> I can't get the Ubuntu intaller to recognize my cdrom. I
>>>>> get to the graphical installer startup, language, location
>>>>> etc., but it  asks for a floppy(!) with my cdrom driver. It
>>>>> asks me to select a module  and then what is the /dev/cdrom
>>>>> address of my drive. It says no common drive found, or 
>>>>> something. I tried /cdrom, /dev/ptmx, /dev/cdrom-which is
>>>>> the default. None work. Any ideas? Is my superdrive cd/dvd
>>>>> dual layer too new or?

It seems like others are having a problem with the new powerbooks:
(or read the whole thread on

One of the problems seems to be with the IDE controller, which may 
explain why the Ubuntu installer doesn't recognize your cdrom drive.

If you read the entire thread, you will see that there is an 
experimental gentoo live CD which apparently boots on this machine:

If you're up for a challenge, this could be fun.  Otherwise, you might 
want to wait a while, until support for this model matures a bit.


More information about the ubuntu-users mailing list