Default to A4 paper in OpenOffice with hp deskjet

Carlos Escutia Chávez carlosescutia at
Thu Nov 3 14:14:04 UTC 2005

I have found a message in this list to enable CUPS web management:

NOW THE SOLUTION as suggested by
doitashimashite suggests bypassing the gnome-cups-manager and dealing
directly with http://localhost:631/admin.

The instructions given there worked a treat and so I have taken the
liberty of quoting them verbatim:

<< from >>

I would suggest to do your printer administration over the Cups Web
Interface instead of the default gnome-cups-manager.

First, for better printer drivers, start Synaptic, enable the universe
repository and install the following packages:


Then, open a terminal (right mouse click on desktop) and execute the
following command:

sudo adduser cupsys shadow

This is needed because the printer administration over the web
interface is by default disabled: the cups deamon needs to read
/etc/shadow and therefore the user cupsys should be added to the group

Now open a web browser (any web browser) and open the URL


and there you are.

If it doesn't work right away, it should after a reboot.

<< end from >>

All I would add is that your system needs to re-read /etc/shadow
before these changes can take effect and the reboot is the most
convenient way of achieving that so don't skip it.

The only other significant thing I did myself was to uncomment the line:
# Port 631
in the Network Options section of /etc/cups/cupsd.conf and in the same
file in the Security Options added (on a line of its own)
to the sub-section starting <Location />

Hope this helps others.


Nigel Pauli
Network Manager
St. John's School, Northwood

2005/11/2, Zach <uid000 at>:
> I do believe that cups requires you to log in as root.  Of course the
> root account on ubuntu systems is disabled (specifically, it doesn't
> have a valid password), since administration is done with sudo.  I
> don't know a way around this  other than to set a password for root.
> As far as the problem regarding paper size in this thread, the way I
> solved it, as mentioned above, was to reconfigure the papersize
> package, specifying the proper paper size, then adding and removing
> printers in gnome.
> On 11/2/05, 'Forum Post <ulist at> wrote:
> >
> > Carlos Escutia Chávez Wrote:
> > > I had this same problem once. What I did to solve it, was configuring
> >
> > > my printer using cups web management tool. Gnome's printer settings
> >
> > > didn't help.
> >
> >
> >
> > Apparently the CUPS web management is no longer available to us. I went
> > to localhost:631/admin and the password dialog came up. I tried several
> > times using "root" and my password, and was unable to login. I finally
> > hit cancel, and the message reported:
> >
> >
> >
> > Cups Web tool Wrote:
> > > Administrative commands are disabled in the web interface for security
> > > reasons. Please use the GNOME CUPS manager (System > Administration >
> > > Printing).
> >
> >
> >
> > If I'm reading this right then there's a password built in to prevent
> > me from accessing the web management on my computer. My next question
> > is how I can get around this...the password must be bypassable if not
> > changeable somehow.
> >
> >
> > --
> > DoomedTX
> >
> > --
> > ubuntu-users mailing list
> > ubuntu-users at
> >
> >
> --
> If you reply to a message I posted to a mailing list,
> and you want me to see your reply, be sure to put my
> address in the 'To:', or I might not see the message.
> --
> ubuntu-users mailing list
> ubuntu-users at

007 - Con licencia para... leer, escribir, ejecutar

More information about the ubuntu-users mailing list