ssh Connection reset by peer problems

Steve Alex svalex at
Fri May 20 15:38:50 UTC 2005


First post and I'll try to be brief.

I posted a bug on Ubuntu bugzilla  
<> that I probably 
shouldn't have.  After two weeks of trying to find something about this 
problem in anything I could Goggle, I though it was my best approach. 
The bug report has some detail, but condensed version:

Installed Ubuntu 5.04 on a Dell Optipex GX450 (PIII 1Ghz) in an attempt 
to move a RMCobol application from an aging System V box.

Everything seemed to work fine with the cobol runtime, but as soon as 
we tried to put the ported system on line, I started to get "Read from 
remote host xxx: Connection reset by peer" errors from ssh connections 
(Mac OS X clients). These disconnects were in the middle of active 

Googled a lot of stuff, fiddled with sshd and ssh config. Moved box to 
different ports, different switches, different cables - same results. 
Moved HD to different box, same results. Posted bug report.

Yesterday I installed Ubuntu on another box, a  small profile Dell G50 
celeroen to see if it was Mac OS X. Ubuntu to Ubuntu had the same 
problem. Then connected from the Mac to the small box and didn't have a 
problem. Thought I had ruled out the ethernet card on a previous test, 
but I swapped hard drives and low and behold, the version generated on 
the small box worked fine in the big box! The original problem build on 
the big box had the same problems in the small box.

I took defaults on both installs, lspci show the same 3Com ethernet.

Being a Mac and Unix person I'm not into kernel generation, but it 
appears that something in the install is not set right. I've got a 
band-aid, in that I have a system that now works (except RMCobol 
responds differently to a bash shell "trap '' 3" built-in command than 
a pure borne shell), but thought someone could explain why this 


More information about the ubuntu-users mailing list