No sound on Intel ICH6-card

crimsun at fungus.sh.nu crimsun at fungus.sh.nu
Tue May 3 21:23:23 UTC 2005


On Tue, May 03, 2005 at 11:37:36AM +0200, Johann Spies wrote:
> Thanks for the reply. I have installed both alsa-source as well as the
> 2.6.10-kernel-source, recompiled the kernel and the alsa-modules and
> installed it. 

There was no need to recompile the kernel. All you needed to do was
to compile the appropriate ALSA driver from 'alsa-source'.

Instructions in /usr/share/doc/alsa-source/README.Debian shed more
light. The critical instruction is the last one (you don't need to
perform all the make-kpkg steps).

> Now the devices are there, but I get no sound.  I have also tried
> installing the polypaudio-packages (after something I saw on the
> Ubuntu-Wiki about sound-problems with Skype), but I still have no
> success.

Uninstalling esd for polypaudio is completely independent of your
sound driver issue. Since you're in this predicament now, please
ensure that you have all the appropriate polypaudio packages
installed - or reinstall all the appropriate esd packages.

For reference, on my system, these are the polypaudio-related
packages that are installed:

libpolyp0, polypaudio, polypaudio-alsa, polypaudio-clients,
polypaudio-x11

[...]
> I have now the following snd-related modules loaded:
> 
> snd_azx                15904  0 
> snd_hda_codec          46912  1 snd_azx
> snd_pcm_oss            53632  0 
> snd_mixer_oss          20000  1 snd_pcm_oss
> snd_pcm                95464  3 snd_azx,snd_hda_codec,snd_pcm_oss
> snd_timer              25892  1 snd_pcm
> snd                    58372  6 snd_azx,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
> soundcore              10208  1 snd
> snd_page_alloc          9988  2 snd_azx,snd_pcm

What is the output of cat /proc/asound/cards?

Ensure that you do not also have i810_audio or ac97_codec loaded.

-- 
Daniel T. Chen          crimsun at fungus.sh.nu
GPG key:   www.sh.nu/~crimsun/pubkey.gpg.asc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20050503/1559af8f/attachment.pgp>


More information about the ubuntu-users mailing list