unseen added devices

Trent Lloyd lathiat at bur.st
Tue May 3 08:12:35 UTC 2005

Are you sure your printer attaches to the serial port? I highly doubt
that, you are most likely looking for the 'parallel port' (The port
looks similar to the older DB25 serial ports)

The printer manager should detect it if its plugged in during boot (you
still have to open printer manager yourself)
If that is not the case, you should be able to add it, using parallel
ort #1

As for the scanner, you might want too look at what those sites had to
say about it working.

Unfortunately 'working' doesn't mean 'works on ubuntu' or 'works with
little effort', it can often mean 'working after some setup and

If you want a list of what ubuntu does out of the box / fairly easy, you
would have to look on the ubuntu site, in the hardware list under the


On Mon, 2005-05-02 at 15:18 -0500, taeb wrote:
> I have been gifted an old scanner (MicroTek SancMaker E3) and an old
> laser printer (HP LaserJet 5MP).  I've looked at various web sites, and
> sane says the scanner is "good" supported, and linuxprinting.org says
> the printer works "perfectly".  I figured I would plug them in, boot,
> and they'd be recognized during boot, and I'd be off to the races.
> There must be more to it than that. :)
> My system: Mac 7300 w/G3 upgrade, running Hoary. 
> I plugged the printer into a serial port after verifying the printer
> worked under Mac OS.  When I tried to configure it using the
> gnome->System->Administration->Printing facility, it did not find any
> local printer.  /dev/ttyS[01] are present, but sending a small file to
> them using cat does not produce any output.  dmesg says they were found
> during boot:
> ttyS0 at MMIO 0xf3013020 (irq = 15) is a Z85c30 ESCC - Serial port
> ttyS1 at MMIO 0xf3013000 (irq = 16) is a Z85c30 ESCC - Serial port
> Similary for the scanner -- a scsi device -- gnome's Xsane image scanning
> device does not see it.  It's been a while since I've tried it -- mostly
> trying to get the printer to work -- so I don't recall what all I've
> tried with it.
> I'm guessing that -- at the very least -- I need to load a module or two
> -- but I have not come across the magic document to indicate what I need
> to do.  Any help or pointers to same would be very much appreciated at
> this point.
> Thanks in advance,
> tony
Trent Lloyd <lathiat at bur.st>
Bur.st Networking Inc.

More information about the ubuntu-users mailing list