Printing woes in Warty

Paul S. Bains slacker at
Wed Mar 23 02:55:22 UTC 2005

This question has been asked many times, but I cannot find a solution.
I am very impressed with Ubuntu, except for printing. I have been
totally unable to print anything to my network printer. Here is my
configuration (I am using Warty on a desktop PC):

Samsung ML1740 laser on a Netgear printserver hooked to my router. The
printserver has it's own IP address and all the Windows machines on my
LAN can print to it. I am using the Gnome print config tool to
configure the printer and have also tried the cups web interface. I set
the printer connection type to "UNIX (LPD)" and have the Host set to
the IP address of my print server. The Queue is the name of the print
server. This configuration has worked on all other Linux distros I have
run in the past, so I know it is not the hardware configuration.

When I attempt to print a test page, occasionally the printer will run
up and I think it's going to print, but then it just stops. Most of the
time absolutely nothing happens. The queue will always show the job,
but it just sits there. I am very frustrated and really don't want to
abandon Ubuntu because I am very impressed by the distro overall.
Printing is an absolute must for me and is a very basic service. I have
over seven years of Linux experience, so am not new to this. Can anyone
shed some light on this problem? Thanks in advance.

More information about the ubuntu-users mailing list