linux-image-2.6.10-5-686-smp: kernel panic - not syncing:attempting to kill init!

Olve Hansen olvesh at
Tue Mar 15 22:20:42 UTC 2005

I have over some time tried to make the 2.6.10 series kernel boot with
my machine (a FS Scaleo T system).

I had a round at this mailing list earlier, then with the 2.6.10-2 kernel:
pivot_root: No such file or directory
/sbin/init: 428 cannot open dev/console: No such file
Kernel Panic - Not syncing: Attempted to kill init!

Last time I found (with the help of Danilo Piazzalunga) that all
modules of relevance was loaded and that the initrd ok.

lsmod gives no sata modules at all, although 
cat /boot/config-2.6.10-5-686-smp |grep -i sata

says all sata drivers are in the form of modules. 

I believe this to be a sata problem, because I am able to boot when I
install the linux-image-2.6.11, but this image hangs later in the
process... For this image to boot I have to switch to AHCI for my sata
controllers, instead of native (in the bios). When booting into 2.6.10
with ahci on, I get another error, a "sata timeout" of some sort. I
don't remember the actual message now, I will write it down in the
next round of tests.

Also when I boot the Preview 1 of the hoary live cd, my sata drives
are given the /dev/hdf and /dev/hdg devices. I have tried to change to
these in grub during boot, resulting in the same error messages..

The message itself is easily reproduced if I give a faulty root
partition to grub during boot.
My head thus tells my that my root partition has gotten another device
node, but I am unable to find which one...   Or that the initrd is
broken in some way..
This is the contents of loadmodules for my current initrd image:
modprobe -k  vesafb > /dev/null 2>&1
modprobe -k  fbcon 2> /dev/null
modprobe -k  fan 2> /dev/null
modprobe -k  thermal 2> /dev/null
modprobe -k  unix 2> /dev/null
modprobe -k  ata_piix
modprobe -k  usb-storage
modprobe -k  sd_mod
modprobe -k  sr_mod

I have tried adding all sata modules available to the
/etc/mkinitrd/modules file, but no change in behaviour.

Other system information that might be of relevance:
Two disks; ST3160023AS, connected to:
IDE interface: Intel Corp. 82801FR/FRW (ICH6R/ICH6RW) SATA Controller (rev 03)

Hope someone can help me nail this problem... Has been bugging me for
some while.


 \ Olve S. Hansen

More information about the ubuntu-users mailing list