encryption (cryptoloop) using array 5

Santanu Chatterjee thisissantanu at gmail.com
Mon Mar 14 08:29:23 UTC 2005

Hi Everybody,

I have an encrypted file containing an ext2 file system that 
I created using cryptoloop and aes encryption under my
Debian Sarge system. I tried to mount that from the Ubuntu
hoary array-4 __Live CD__, but could not.

I loaded the cryptoloop and aes_i586 kernel modules, and then
used the command :
mount -t ext2 -o loop,encryption=aes-256 ./encrypted.aes /mnt/
but after giving the correct password, I get the error message
telling me something like "ioctl: LOOP_SET..." and tells me something
about "invalid argument" (sorry, I don't remember the exact error,
but I will provide it in a couple of days if required).

The interesting thing is, I could use the same command  to mount
the file under other _installed_ Linux OSs like Mandrake 10.1, and
Fedora. However, I get this kind of errors (not the exact same error,
though) under all the _LiveCDs_ that I have tried (Knoppix, Array-5, etc)

Can anyone please tell me what could be the cause of this problem?


More information about the ubuntu-users mailing list