Getting hopeless on Hoary

Eamonn Sullivan eamonn.sullivan at gmail.com
Sat Mar 12 21:54:21 UTC 2005


Forgive me a moment while I express some frustration: Getting sound to
work has been a bit of a nightmare in Hoary. I mean no disrespect for
any of the developers. I know it's hard, and apparently some people
have no problems. But for me, the last few weeks has been one problem
after another. When one thing is fixed, another breaks.

- When Hoary was using polypaudio, everything worked perfectly, other
than the intro and exit sounds (I could definitely live without
those). But just for me. No one else who logged in after me could get
any sound. The wife and kids weren't amused.

- OK, devs drop polypaudio and revert to esound. Now everyone can get
sound, even the intro and exit jingle. But now skype stops working,
after it was working perfectly under Warty and polypaudio. When I
start skype by itself, it hangs while trying to connect. When I start
skype with esddsp ("esddsp skype"), it appears to connect, but I hear
nothing. At least it doesn't hang.

- Today I discovered that RealPlayer 10 doesn't work. I tried removing
and reinstalling. I tried Real's installer and I tried alien on the
rpms (both methods seem to result in identical setups). When I type
realplay in a shell, it just hangs before anything displays. When i
try strace on it, I don't see anything out of the ordinary, it just
hangs  in the middle of a waitpid ("waitpid(-1, ").

- I just checked and found out that VLC doesn't work either. When I
try to open an AVI file I just viewed last week, I get the video fine,
but no audio.

What does work: Rhythmbox still works fine (playing straight MP3s,
shoutcast, etc.) and I still get all the system sounds. I'm using
Intel motherboard sound -- Intel ICH5 AC'97.

I just realised that there *is* a common thread among the applications
that don't work: OSS. RealAudio, VLC and Skype all use OSS, while the
stuff that does work have joined the 21st century and use Alsa or
esound. But if I try to choose OSS in System/Multimedia System
Selector (which is set to ESD at the moment) I get "Failed to
construct test pipeline for 'OSS - Open Sound System'

Is anyone else also having problems with RealPlayer, Skype or VLC?
Anyone have a suggestion on what I can try next?

-Eamonn




More information about the ubuntu-users mailing list