Internet no longer working?

Todd Deshane deshantm at
Fri Jun 17 16:06:14 UTC 2005

I don't have much experience setting up DNS stuff that usually works...

but I do remember having to manually set DNS servers when I 
had a server from my ISP once that was hard coded. You could
check in the network settings in System->Administration->Networking
there is a DNS tab, make sure that you ISP's DNS server(s) are in there
for the card you are usually externally.

Hope that helps,

On 6/17/05, Arjan Geven <arjangeven at> wrote:
> Hey Todd, list,
> On 6/16/05, Todd Deshane <deshantm at> wrote:
> > Have you tried switching the roles of the cards?
> > eth0 being the default gateway instead of eth1 for example...
> I'm now 100% sure about the places and roles of eth0 and eth1, this I
> definitely put on the right places. As you suggested, I switched the
> role of the cards, but then I wouldn't obtain an IP-address from my
> ISP anymore. eth1 is definitely the one that goes to the ISP, and eth0
> the one that connects to my laptop. The strange thing is that it
> worked at first, but then just failed after a while.
> > Also which cards is windows working through, could it
> > be that one of the cards is bad?
> Both cards and "internet connection sharing" work flawlessly in Windows.
> > I don't completely understand what you are trying to do
> > so if that is way off, sorry. Otherwise, please clarify
> > what you know is working and what is not and exactly
> > what you want to do with the multiple cards and connections
> Reading my own message again makes me realize I didn't quite formulate
> my problem so well. So, let's try again....
> schematic:
> cablemodem -> eth1 | main computer | eth0 -> laptop.
> The cablemodem is plugged in at eth1 of the main computer and the
> laptop at eth0. The main computer is configured to get an IP-address
> over eth1 and forward the internet to the laptop over eth0. This
> worked with dnsmasq the first time I tried.
> Then, after a while, my ISP dropped the connection, I couldn't visit
> any webpage anymore. The only thing I could still do was send a ping
> to my ISP. Anything more than that would result in "DNS Server
> temporarily not available". I then added some OpenNIC DNS servers, but
> this did not help.
> I first thought this was a problem on ISP level, and that they had
> some network problems. However, the whole thing works in Windows XP,
> so it must be my Ubuntu configuration. But I have no idea where to
> look anymore.
> Arjan

More information about the ubuntu-users mailing list