Old World Mac

Peter Gort pgort at iprimus.com.au
Sun Jun 12 12:05:51 UTC 2005

On Sat, 2005-06-11 at 17:10 -0500, Cybe R. Wizard wrote:
> Peter Gort <pgort at iprimus.com.au> wrote:
> > Oops, I just found the web page devoted to this subject, sorry for  
> > the wasted bandwidth!
> Care to share?  It's always possible the subject will be of interest
> to
> others in the future.


I mostly followed this, with the exception that at boot loader section,
when I had to copy the vmlinux and initrd files to the mac side, I went
to the Installer Main screen (Hoary Installer) opened a shell session,
and did 

makedir /mnt
makedir /mnt/mac
mount -t hfs /dev/sdb5 /mnt/mac
(Mac OS is on second scsi hard drive, partition 5).

cp /target/boot/* /mnt/mac

then returned to the installer and let it complete normally.

then I rebooted into Mac OS and set up the new vmlinux and initrd files
in BootX.

One catch remains, when I ran the installer I had a text screen that
worked fine, but rebooting into the installed system leaves me with no
video whatsoever, no text, no X, nothing.  Probably a parameter I have
to pass to the kernel at boot, but I have no idea what, and I've had
enough fun for today, if I don't pay attention to the family soon I'll
get divorced....

Oh, the machine is a Mac 7600/132 with a 14" 640*480 colour Mac monitor
attached.  Was a AppleScript Robot many years ago....and ran for 18
months before I went into the server room to check on it's status.
Definitely a reliable machine, albeit slow.


More information about the ubuntu-users mailing list