Bad Xorg symbolic link in Breezy (SOLVED!)

Bob Nielsen nielsen at
Thu Jun 2 00:16:49 UTC 2005

On Thu, Jun 02, 2005 at 05:25:53AM +1000, Daniel Stone wrote:
> On Wed, Jun 01, 2005 at 09:46:50AM -0700, Bob Nielsen wrote:
> > It looks like -21 is broken also.  It (probably an installation script) 
> > recreated the bad symlink from /usr/X11R6/bin/Xorg to itself.  When I 
> > tried the same tactic I used for -20 (above), that didn't work, since 
> > Xorg is only a 7460 byte file which won't execute!
> xserver-xorg pre-depends on x-common (>= 1.0), which will make
> /usr/bin/X11 a directory, among other things.  Obviously bad things
> will happen if x-common gets installed, /usr/bin/X11 gets made a
> symlink to 'fix' other problems, and xserver-xorg gets installed, in
> that order.

Apparently that is exactly what happened, although I don't know how (as 
I said before all was working with -16.
Indeed /usr/bin/X11 WAS a symlink to /usr/X11R6/bin.  I removed that 
symlink and created /usr/bin/X11 as a directory then reinstalled
xserver-xorg and all seems fine.  Thanks for the explanation.


More information about the ubuntu-users mailing list