K3B, better: cdrecord is not able to burn cds on a scd0-devic- PROBLEM SOLVED

hagen van rissenbeck news4didascali at gmx.net
Thu Jul 28 20:18:00 UTC 2005

Hi list, hi Derek, hi Ziyad,

Thanks for your help...

I solved the problem on that laptop, I wrote about, yesterday morning. 
To continue, please have a look at the bottom of that mail...

On Thu, 2005-07-28 at 13:46 -0300, Derek Broughton wrote:

>>I didn't change any defaults (in fact, I just did a complete new hoary
>>install) and my DVD is /dev/cdrom -> /dev/scd0.  I admit, I haven't
>>actually tried writing anything on it since the reinstall...


> Is your DVD a SCSI device by any chance?  If not, then there's something
> not right with your setup.  If yes, check the ownership of "/dev/scd0":
>         ls -l /dev/scd0
> Normally, it should be owned by "root" and group "cdrom" and
> readable/writable by "root" and anyone in that group.  Make sure you're
> in that group by running "groups".
> If that's not the case, grant yourself a write permission to that
> device.  For example, by changing it's group to "cdrom", adding yourself
> to that group, and changing the permission to "ug=rw,o=" like this:
>         sudo chmod ug=rw,o= /dev/scd0
> (Note there's a space after "chmod" and before "/dev/scd0".)
> Ziyad.

I googled a while.

That seemed/seems to be a problem also on other distros, too. I've read 
postings on suse or slackware lists as well, BTW.

First, you have to be sure, that the user who would like to burn, should 
be a member of the cdrom group.

2nd: go to


and have a look on the rights of that cdrom-binary-file. Take care, that 
SUID (set user id) is activated!

Wikipedia writes (citation):

"Setuid is a UNIX term, and is short for "Set User ID." Setuid, also 
sometimes referred to as "suid," is an access right flag that can be 
assigned to files and directories on a UNIX based operating system. The 
setuid flag is mostly used to allow users on a computer system to 
execute binary executables with temporarily elevated privileges in order 
to perform a specific task."

... and that's what the "cdrom" command needs to open the device.

(for more, see: http://en.wikipedia.org/wiki/Suid)

After I did that, I was able to start burning a cd as a normal user.

I would like to ask experts on the list, if that procedure is ok for 
safety reasons?


More information about the ubuntu-users mailing list