X is black after removing all files /tmp files

ZIYAD A. M. AL-BATLY zamb at saudi.net.sa
Thu Jul 28 06:52:22 UTC 2005

On Wed, 2005-07-27 at 22:29 -0700, Charlie Zender wrote:
> Hi,
> I successfully installed Ubuntu Hoary on a Dell Inspiron 7500,
> but now the X display doesn't work. It worked fine after the
> original installation then I did something stupid and now the
> X display appears totally black, i.e., it's running but you
> can't see anything. What happened is that I accidentally
> deleted all the files and directories in /tmp while X was
> running, i.e., I deleted the gconfd-zender, gpg-tEoLTf,
> mapping-zender, orbit-zender directories.
> Then I rebooted and now X is "back in black".
> I tried removing then re-installing the X server and gnome
> but that did not work. The screen is still black.
>  From what I can surmise, there must be an X or gnome config file
> somewhere besides /tmp that contains state-ful information that
> I must manually delete before the system can reset itself correctly.
> Anyone know how to get my X back without re-installing Ubuntu from
> scratch?
> Thanks,
> Charlie
> -- 
> Charlie Zender, surname at uci.edu, Department of Earth System Science
> University of California, Irvine CA 92697-3100. Tel: (949) 824-2987
>From a console (press CTRL+ALT+F1 and then login) do:
        sudo /etc/init.d/gdm stop
        sudo rm -r -f /tmp/* /tmp/.X* /tmp/.ICE* /tmp/.gdm*
        sudo /etc/init.d/xorg-common start
        sudo /etc/init.d/gdm start

See if that fixes your problem.  If not, then it's most likely a GNOME
problem and not X (to make sure, does it start GDM or not?  If GDM
starts normally, then your problem is definitely a GNOME one).  Try
creating a new user using (again, from a console):
        sudo adduser

and answer the questions.  Switch to X by pressing ALT+F7 and login
using that new user ID.  If it works, then all you need to do is reset
your original user ID's GNOME session settings by deleting
"~/.gnome2/session*" and "~/.gnome2/.gnome-smproxy*".

Hope this fix your problem.

More information about the ubuntu-users mailing list