[Breezy] X won't start, following today's update ?

Stephen R Laniel steve at laniels.org
Mon Jul 4 16:50:50 UTC 2005


On Mon, Jul 04, 2005 at 12:20:32PM -0400, Stephen R Laniel wrote:
> Ah so. All fixed. Thanks, Daniel.

Hm. I rebooted, and got an error when GDM was supposed to
start, saying that /etc/X11/X wasn't executable. I looked at
it, and it was a symlink to /usr/bin/X11/Xorg-debug. The
latter no longer exists, even though the package is
installed:

xserver-xorg-dbg				install

So I have a couple questions:

1) What happened to /usr/bin/X11/Xorg-debug? Even doing a
'which Xorg-debug' brings up nothing.

2) I suspect that the xorg installer didn't overwrite
/etc/X11/X with its own new symlink because I had manually
set that to symlink to Xorg-debug during an earlier problem
getting X to run. So from now on, even when files change,
will that symlink stay unchanged? I sometimes see during
installation that dpkg has left various xorg files unchanged
because I customized them; I'd like to tell dpkg, "No, go
ahead and change them." Is there any way to do this?

-- 
Stephen R. Laniel
steve at laniels.org
+(617) 308-5571
http://laniels.org/
PGP key: http://laniels.org/slaniel.key
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20050704/5a44ed6c/attachment.pgp>


More information about the ubuntu-users mailing list