[Breezy] X won't start, following today's update ?

Vincent Trouilliez vincent.trouilliez at modulonet.fr
Mon Jul 4 15:20:43 UTC 2005

> Hm. Not so for me, unfortunately:
> Preparing to replace libx11-6 1:6.2.1+cvs.20050615-3 (using .../libx11-6_1%3a6.2.1+cvs.20050615-4_i386.deb) ...
> Unpacking replacement libx11-6 ...
> dpkg: error processing
> /var/cache/apt/archives/libx11-6_1%3a6.2.1+cvs.20050615-4_i386.deb (--unpack): trying to overwrite `/usr/lib/X11/XErrorDB', which is also in package xlibs-data
> Lots of other packages return similar errors.

Ah yes, I ran into this problem when I updated earlier today. What I did
is I ran the update manager, and "unticked" the checkbox next to this
package. All the other packages then installed correctly. Then, only
this libx11 was left. I ticked the checkbox, and it installed fine. Go
figure. Then I logged out and restarted X, which is were X refused to
start, hence my OP...
Maybe I should not have tried to work around this libx11 problem, and
just waited a few days for the error to be corrected, before
updating... ?

Would be nice to have the devs opinion on the action to undertake in
such circumstances... "force" the install somehow, or let it cure by
itself until it all install "cleanly" ?


More information about the ubuntu-users mailing list