The continuing saga of my USB memory key

Nick Mirkovich nickm1 at
Thu Sep 30 13:03:45 UTC 2004

	First of all, there is some conflicting opinions on how wise it is to
mess with /mnt. IMO, you shouldn't go that way. Leave /mnt alone and
create a new mount point elsewhere keeping in mind that unless it's in
your home directory, you'll have to be root to create the new mount
point. Make sure you set permissions accordingly to allow non-root users
the appropriate privileges to the mount point.
	The fstype, or -t flag, ought to be vfat not fat, at least this true in
a straight Debian system.
	Here is an example from my /etc/fstab where I created to mount for my
USB flash drive:

/dev/sdb1       /fdrv           vfat    rw,user,noauto          0      

In my case, the USB drive is /dev/sdb1 and the mount point is /fdrv.

Hope this helps,

On Thu, 2004-09-30 at 00:49, Ben Novack wrote:
> A correction - I actually typed sudo mount /dev/sda /mnt/usbdrive -t fat.
> Tried it with both the flash drive and the HD.
> Also, I tried manually making a /mnt/usbdrive directory, Got the same error.
> On Thu, 30 Sep 2004 00:14:22 -0400, Ben Novack <bennovack at> wrote:
> > I ran demsg, but I can't post its contents because I've got no way to
> > get anything off of Ubuntu - I have no network access because I can't
> > get to neccessary packages on my USB key, which is the whole problem.
> > 
> > When I plug in my USB key or external HD, it's seen and recognized
> > with scsi emulation at sda - but it's not mounted, and my newbie
> > attempts to manually mount (sudo mount /dev/sda /mnt/usbdrive) lead to
> > complaints that the mountpoint doesn't exist.
> > 
> > Any ideas, or specific things I should look for?
> > 
> > Danke,
> > 
> > ---BHN
> >

More information about the ubuntu-users mailing list