DNS timing out? (was: Network Help)

Olafur Arason olafra at gmail.com
Thu Sep 30 08:51:15 UTC 2004

In lynx, firefox and epiphany it takes from 10 - 20 sek to get a page up because
the browser is looking for the address. If you enter the ip address it comes up
like a flash. I tried static and dhcp network, ipv6 on and off. I got it working
on one computer but I don't know how I did it. I also tried dns-autolookup and
alot of other things with dns and dhcp in the name and resolveconf. I tried diff
dpkg -l comparison and a etc diff comparison. Ping, dig, host and dnstracer are
simular on those two machines. Fedora core 1 has no problem on the same machine.

>On Sat, 18 Sep 2004, Bert Martin wrote:
>> I have one problem though.  My web browser is very slow to pull up
>> pages.  It waits for ever to resolve the host name and then even longer
>> to load the page.  I tried a ping to www.yahoo.com and it was very fast.
>Sounds like the first DNS server that has been configured (probably
>automatically by DHCP) may not be responding.
>You can see the DNS servers that are trying to be used, by looking in:
>   /etc/resolv.conf
>If you have 'host', or 'dig' on the system (or anyother system), you could
>try one of the following commands:
>  $ dig www.ubuntulinux.org @
>  $ host www.ubuntulinux.org
>where '' would be replaced with the DNS servers in your
>'resolv.conf', and see if it times out.
>	-Paul
>Note: libresolv should probably be fixed so that if a request fails, it
>starts preferring the resolvers it has available, rather than continuing to
>try the first one on every occasion...
>Is there no safe way to travel?  Nottingham, GB

More information about the ubuntu-users mailing list